do-release-upgrade crashed

Bug #158872 reported by Richard T. Bumby on 2007-10-30
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

I have been using kpackage to keep my system up to date. To upgrade to gutsy, I started adept and was supposed to see a tool to do the upgrade, but it was disabled. In one of the packages, I saw a script called do-release-upgrade and tried it (first on a 64 bit system that I use for testing, and when that was successful, I tried to upgrade the 32 bit installation on the same machine). Download went smoothly, but I hit an early snag with this error message

Errors were encountered while processing:
 coreutils
 linux-doc-2.6.22
 linux-doc

and ending with

Could not install the upgrades
The upgrade aborts now. Your system could be in an unusable state. A recovery wi
ll run now (dpkg --configure -a).

Please report this bug against the 'update-manager' package and include the file s in /var/log/dist-upgrade/ in the bugreport.
installArchives() failed
Setting up coreutils (5.97-5.3ubuntu3) ...
install-info: No dir file specified; try --help for more information.
dpkg: error processing coreutils (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-doc-2.6.22:
 linux-doc-2.6.22 depends on coreutils | fileutils (>= 4.0); however:
  Package coreutils is not configured yet.
  Package fileutils is not installed.
dpkg: error processing linux-doc-2.6.22 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-doc:
 linux-doc depends on linux-doc-2.6.22; however:
  Package linux-doc-2.6.22 is not configured yet.
dpkg: error processing linux-doc (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 coreutils
 linux-doc-2.6.22
 linux-doc

This page was the only place I say to report the error, but I have not yet seen a way to attach the logs.

Richard T. Bumby (bumby) wrote :
Marco Rodrigues (gothicx) wrote :

Hi!

Try to do $ sudo apt-get autoclean

and try again the $ sudo update-manager -d

Thanks!

Changed in update-manager:
importance: Undecided → Low

Marco Rodrigues wrote:
> Hi!
>
> Try to do $ sudo apt-get autoclean
>
> and try again the $ sudo update-manager -d
>
> Thanks!
>
> ** Changed in: update-manager (Ubuntu)
> Sourcepackagename: None => update-manager
>
> ** Changed in: update-manager (Ubuntu)
> Importance: Undecided => Low
>
>
Thank you. This allowed a successful upgrade to gutsy.

--RTBumby

Changed in update-manager:
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments