update-manager produces PyGIWarning messages re imports

Bug #1573177 reported by Chris Taklis (aka Kailor) on 2016-04-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

i upgraded to 16.04. Suddenly it shows a bug and stops the upgrade. When it finished, i tried again and i rebooted. It shows that has upgraded to 16.04 but when i write sudo update-manager it show the following message.

"/usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
  from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
  from gi.repository import Dbusmenu, Unity"

Via lsb_release-rd:

Description: Ubuntu 16.04 LTS
Release: 16.04

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.12
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Thu Apr 21 21:13:18 2016
InstallationDate: Installed on 2015-04-03 (384 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)
VarLogDistupgradeTermlog:

mtime.conffile..etc.update-manager.release-upgrades: 2016-04-21T19:57:21.515933

Same here.

My upgrade from 12.04 to 16.04 was freezed. I rebooted and finished with dpkg --configure -a. Next I launched the upgrade-manager and got that warning message (I also had to do a partial upgrade).

Brian Murray (brian-murray) wrote :

I see these warnings also, but I am still able to use update-manager. Are you not able to?

affects: ubuntu-release-upgrader (Ubuntu) → update-manager (Ubuntu)
Changed in update-manager (Ubuntu):
status: New → Incomplete
Masi (soopo) wrote :

Same problem here.

I opened a thread about my situation here: http://unix.stackexchange.com/q/286903/16920

The problem is generally about incomplete upgrade to 16.04. I upgraded from 14.04. I know exactly which was my last package that I managed to install in the upgrade process, until my disk space was full. Now, I have done many update and upgrade cycles but not yet get fully working 16.04. Changing sources.list content by the sources list generator helped a lot.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
Changed in update-manager (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

@Chris - Could you answer my question from comment #3? Thanks!

Changed in update-manager (Ubuntu):
status: Confirmed → Incomplete

@Brian yes i am able to use update-manager too...

After so many months (since April) and after so many upgrades i think all problems have solved. Or at least i don't have any problem now in my system.

Brian Murray (brian-murray) wrote :

Thanks, I'm going to make this bug about the warnings re PyGI then.

Changed in update-manager (Ubuntu):
status: Incomplete → Triaged
importance: High → Low
summary: - sudo update-manager bug after upgrade on 16.04
+ update-manager produces PyGIWarning messages re imports
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.10.5

---------------
update-manager (1:16.10.5) yakkety; urgency=medium

  [ Brian Murray ]
  * UpdateManager/UpdateManager.py: when marking HWE packages for install pass
    on a SystemError and let the problem resolver sort it out.
  * HweSupportStatus/consts.py: Improve wording of the messages.
  * hwe-support-status:
    - decode output when checking for foreign architectures so that the result
      is unicode not bytes.
    - add libwayland-egl1-mesa to the list of metapackages.
    - utilize a virtualbox metapackage set.
    - Do not show replacements that are already installed on
      the system. (LP: #1607983)
  * source_update-manager.py: collect information about the state of HWE
    support on the system. (LP: #1617080)
  * source_update-manager.py: only collect HWE information if it exists.

  [ Jeremy Bicha ]
  * Add gi.require_version in a few more places to reduce the annoying
    warnings. (LP: #1573177)

 -- Brian Murray <email address hidden> Thu, 08 Sep 2016 16:01:13 -0700

Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
MR Zenwiz (mrzenwiz) wrote :

I notice that the fix was released for 16.10. I haven't seen a backport for 16.04 LTS users like me. When is that going to happen?

Thanks.

Brian Murray (brian-murray) wrote :

It's just a warning message and as such doesn't really warrant a Stable Release Update.

MR Zenwiz (mrzenwiz) wrote :

It may just be a warning, but my software updater no longer functions at all.

The updater indicator remains a red dot with the white line through it, and the updater fails every
time. If I click on the "Show Updates", it does nothing. If I click "Check for updates", it goes out and get the updates to display, but when I click on "Install Now", the updater shows a blank update window and never does anything.

Is this something different?

Thanks.

On Wed, Jan 25, 2017 at 11:26:23PM -0000, MR Zenwiz wrote:
> It may just be a warning, but my software updater no longer functions at
> all.
>
> The updater indicator remains a red dot with the white line through it, and the updater fails every
> time. If I click on the "Show Updates", it does nothing. If I click "Check for updates", it goes out and get the updates to display, but when I click on "Install Now", the updater shows a blank update window and never does anything.
>
> Is this something different?

Yes.

--
Brian Murray

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers