Asked twice about ssh daemon

Bug #156625 reported by Matt Zimmerman on 2007-10-24
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt
Hardy
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

During a server upgrade with "sudo do-release-upgrade", I was asked twice about starting an ssh daemon on port 9004. This seems like a handy precaution, but it should only be necessary to ask once.

norman% sudo apt-get install update-manager-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
update-manager-core is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
norman% sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting '/tmp/tmp_G0z5h/gutsy.tar.gz'
authenticate '/tmp/tmp_G0z5h/gutsy.tar.gz' against '/tmp/tmp_G0z5h/gutsy.tar.gz.gpg'

Reading cache

Checking package manager

Continue running under SSH?
This session appears to be running under ssh. It is not recommended to perform an upgrade over ssh at present, because in case of failure it is harder to recover.

If you continue, an additional ssh daemon will be started at port '9004'.
Do you want to continue?
Continue [yN] y

Starting additional sshd
To make recovery in case of failure easier an additional sshd will be started on port '9004'. If anything goes wrong with the running ssh you can still connect to the additional one.

Reading package lists: Donefeisty-security/restricted Packages: 96
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done http://security.ubuntu.com feisty-security Release.gpg
Done http://archive.canonical.com feisty-commercial Release.gpg
Done http://archive.canonical.com feisty-commercial Release
Done http://gb.archive.ubuntu.com feisty Release.gpg
Done http://gb.archive.ubuntu.com feisty-updates Release.gpg
Done http://gb.archive.ubuntu.com feisty-backports Release.gpg
Done http://security.ubuntu.com feisty-security Release
Hit http://gb.archive.ubuntu.com feisty Release
Done http://gb.archive.ubuntu.com feisty-updates Release
Done http://gb.archive.ubuntu.com feisty-backports Release
Done http://archive.canonical.com feisty-commercial Release
Done http://archive.canonical.com feisty-commercial/main Packages
Done http://security.ubuntu.com feisty-security Release
Done http://security.ubuntu.com feisty-security/main Packages
Done http://security.ubuntu.com feisty-security/restricted Packages
Done http://security.ubuntu.com feisty-security/main Sources
Done http://security.ubuntu.com feisty-security/restricted Sources
Done http://archive.canonical.com feisty-commercial/main Packages
Done http://gb.archive.ubuntu.com feisty Release
Hit http://gb.archive.ubuntu.com feisty/main Packages
Hit http://gb.archive.ubuntu.com feisty/restricted Packages
Hit http://gb.archive.ubuntu.com feisty/universe Packages
Hit http://gb.archive.ubuntu.com feisty/multiverse Packages
Hit http://gb.archive.ubuntu.com feisty/main Sources
Hit http://gb.archive.ubuntu.com feisty/restricted Sources
Done http://gb.archive.ubuntu.com feisty-updates Release
Done http://gb.archive.ubuntu.com feisty-updates/main Packages
Done http://gb.archive.ubuntu.com feisty-updates/restricted Packages
Done http://gb.archive.ubuntu.com feisty-updates/main Sources
Done http://gb.archive.ubuntu.com feisty-updates/restricted Sources
Done http://gb.archive.ubuntu.com feisty-backports Release
Done http://gb.archive.ubuntu.com feisty-backports/main/debian-installer Packages
Done http://security.ubuntu.com feisty-security/main Packages
Done http://security.ubuntu.com feisty-security/restricted Packages
Done http://security.ubuntu.com feisty-security/main Sources
Done http://security.ubuntu.com feisty-security/restricted Sources
Done http://gb.archive.ubuntu.com feisty-updates/main Packages
Done http://gb.archive.ubuntu.com feisty-updates/restricted Packages
Done http://gb.archive.ubuntu.com feisty-updates/main Sources
Done http://gb.archive.ubuntu.com feisty-updates/restricted Sources
Done http://gb.archive.ubuntu.com feisty-backports/main/debian-installer Packages
Done downloading
http://gb.archive.ubuntu.com feisty-backports/main/debian-installer Packages: 96Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done http://gb.archive.ubuntu.com feisty-backports/main/debian-installer release-upgrader-dpkg 1.14.5ubuntu11.2
Done http://gb.archive.ubuntu.com feisty-backports/main/debian-installer release-upgrader-apt 0.6.46.4ubuntu10.3
Done downloading

Reading cache

Checking package manager

Continue running under SSH?
This session appears to be running under ssh. It is not recommended to perform an upgrade over ssh at present, because in case of failure it is harder to recover.

If you continue, an additional ssh daemon will be started at port '9004'.
Do you want to continue?
Continue [yN] y

Starting additional sshd
To make recovery in case of failure easier an additional sshd will be started on port '9004'. If anything goes wrong with the running ssh you can still connect to the additional one.

Reading package lists: Donefeisty-security/restricted Packages: 96

Michael Vogt (mvo) on 2007-10-24
Changed in update-manager:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → hardy-alpha-1
status: New → Confirmed
Steve Langasek (vorlon) on 2007-12-06
Changed in update-manager:
milestone: hardy-alpha-1 → hardy-alpha-2
Steve Langasek (vorlon) on 2007-12-15
Changed in update-manager:
milestone: hardy-alpha-2 → ubuntu-8.04-beta
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This is fixed in bzr now and will be part of the next upload.

Changed in update-manager:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.87.13

---------------
update-manager (1:0.87.13) hardy; urgency=low

  * DistUpgrade/DistUpgradeController.py:
    - only ask once about the sshd (LP: #156625)
  * DistUpgrade/DistUpgradeCache.py:
    - add hardyQuirks handler to deal with a
      gnome-translate upgrade issues (thanks to Daniel Holbach)
    - fix naming of the quirksHandlers
  * DistUpgrade/DistUpgrade.cfg:
    - add "ksplash-engine-moodin" to ForcedObsoletes
  * DistUpgrade/removal_blacklist.cfg:
    - add "^postgresql-.*"to the removal blacklist
  * DistUpgrade/DistUpgradeViewText.py:
    - flush() output in updateStatus()
    - show the demoted packages in a more readable
      manner
    - use textwrap when displaying text
  * DistUpgrade/DistUpgradeCache.py:
    - fix bug that prevented proper error message on
      upgrade calculation error in the text frontend
    - fix text download progress
  * DistUpgrade/ReleaseAnnouncement
    - updated for BETA

 -- Michael Vogt <email address hidden> Thu, 20 Mar 2008 16:06:56 +0100

Changed in update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers