[kde] RuntimeError: underlying C/C++ object has been deleted (was: Upgrade tool crashed Kubuntu Feisty to Gutsy)

Bug #156102 reported by jolay on 2007-10-23
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Jonathan Riddell

Bug Description

Binary package hint: update-manager

uname -r => 2.6.20-16-generic #2 SMP Amd64
Traceback (most recent call last):
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/dist-upgrade.py", line 59, in <module>
    app.run()
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeControler.py", line 1346, in run
    self.fullUpgrade()
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeControler.py", line 1328, in fullUpgrade
    if not self.doDistUpgrade():
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeControler.py", line 798, in doDistUpgrade
    res = self.cache.commit(fprogress,iprogress)
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeCache.py", line 69, in commit
    apt.Cache.commit(self, fprogress, iprogress)
  File "/usr/lib/python2.5/site-packages/apt/cache.py", line 203, in commit
    if fetchProgress == None:
  File "/usr/lib/python2.5/site-packages/apt/cache.py", line 178, in installArchives
    # this can throw a exception
  File "/usr/lib/python2.5/site-packages/apt/progress.py", line 219, in run
    res = self.waitChild()
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeViewKDE.py", line 315, in waitChild
    self.updateInterface()
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeViewKDE.py", line 285, in updateInterface
    InstallProgress.updateInterface(self)
  File "/usr/lib/python2.5/site-packages/apt/progress.py", line 194, in updateInterface
    self.conffile(match.group(1), match.group(2))
  File "/tmp/kde-root/adept_managerNNsEAb.tmp-extract/DistUpgradeViewKDE.py", line 228, in conffile
    self.parent.konsole.sendInput("y\n")
RuntimeError: underlying C/C++ object has been deleted

jolay (jo-lay) wrote :
jolay (jo-lay) wrote :
jolay (jo-lay) wrote :

Since all the packages were downloaded :
dpkg -- configure -a
partially solved the problem (after few back and forth using adept dist-upgrade).
Kernel 2.6.22-14-generic SMP Amd 64 seems to work.
adept still reports a possible dist-upgrade.

Mario Young (mayeco) on 2007-10-24
Changed in update-manager:
assignee: nobody → mvo
Michael Vogt (mvo) on 2007-10-24
Changed in update-manager:
assignee: mvo → jr
importance: Undecided → High
status: New → Confirmed
Jonathan Riddell (jr) wrote :

Fixed in current releases

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments