Can't Upgrade to 7.10 using Alternate CD

Bug #155394 reported by Ravi Chhabra on 2007-10-21
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I have upgraded from Edgy to Feisty (when Feisty came out). Now using the Alternate CD I have tried upgrading to Gibon, but it fails. I choose not to download additional files from the internet as I have a very slow connection. The messages that I get is as follows:

Can't install 'ubuntu-desktop'

It was impossible to install a required package. Please report this as a bug.

Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

Ravi Chhabra (ravi-chhabra) wrote :
Ravi Chhabra (ravi-chhabra) wrote :
Ravi Chhabra (ravi-chhabra) wrote :
Ravi Chhabra (ravi-chhabra) wrote :
Sanhe (sanhex) wrote :

me too.
I think ubuntu could not upgrade from CD without Internet connection, even if we didn't got this error.
Because some of your software packages may not be contained in the CD/DVD, so you must download them from the Internet repository during the upgrade process.
I find a way to download less packages from Internet when you upgrade to ubuntu7.10. Of course you should have a Internet connection first.

1. Run update-manager, upgrade from the Internet, after the apt source setting process (when it is downloading the package files), cancel it.
2. Upgrade from CD/DVD, you may find the problem above is resolved.

But if you have installed some packages which are not included in the alternate CD, then these packages will still be downloaded from the Internet.
It means you can get most of the packages from CD, less from Internet.
PS: I need to download more than 1300 packages during the upgrade process, 994 was from the CD, the others was downloaded from the Internet.

Educarrega (educarrega) wrote :

i'm user from Kubuntu, and see same error:
"A unresolvable problem occurred while calculating the upgrade."
command: kdesu sh /cdrom/cdromupgrade

Niels Grundtvig Nielsen (ngn) wrote :
Niels Grundtvig Nielsen (ngn) wrote :
Niels Grundtvig Nielsen (ngn) wrote :
Niels Grundtvig Nielsen (ngn) wrote :

I'm marking it as confirmed.

Changed in update-manager:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 46245, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Download full text (4.8 KiB)

My fault: it's not a duplicate of bug 46245.
It's quite difficult to find a duplicate of it.
May help...:

From main.log:
2007-10-21 21:40:11,707 ERROR failed to mark 'ubuntu-desktop' for install (E:Unable to correct problems, you have held broken packages.)
2007-10-21 21:46:15,562 ERROR Dist-upgrade failed: 'Can't upgrade required meta-packages'

From apt.log:
ERROR:root:Unauthenticated packages found: 'afio apache2 apache2-mpm-prefork app-install-data app-install-data-commercial apport apport-gtk bind9-host capplets-data curl dbus dbus-1-utils democracyplayer democracyplayer-data dnsutils edgy-community-wallpapers evolution-data-server evolution-data-server-common festival ffmpeg file firefox firefox-gnome-support flashplugin-nonfree gawk gimp gimp-data gimp-python gnome-app-install gnome-btdownload gnome-control-center gnome-media gnome-media-common gnome-panel gnome-panel-data gstreamer0.10-ffmpeg gstreamer0.10-gl gstreamer0.10-pitfdll gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gtkhtml3.8 hal hal-device-manager hal-info hwdb-client-common hwdb-client-gnome iptables lame language-pack-en language-pack-gnome-en lftp liba52-0.7.4 libapache2-mod-auth-mysql libartsc0 libavcodec0d libavformat0d libbind9-0 libboost-program-options1.33.1 libboost-python1.33.1 libboost-regex1.33.1 libboost-signals1.33.1 libboost-thread1.33.1 libbtctl4 libcamel1.2-10 libcurl3 libcurl3-gnutls libdbd-mysql-perl libdbi-perl libdbus-1-3 libdc1394-13 libdns22 libdvdnav4 libdvdread3 libebook1.2-9 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8 libegroupwise1.2-13 libestools1.2 libexchange-storage1.2-3 libexif12 libfreebob0 libfreetype6 libggi2 libgii1 libgii1-target-x libgimp2.0 libgl1-mesa-dri libgl1-mesa-glx libglib1.2 libglide2 libglu1-mesa libgnome-media0 libgnome-window-settings1 libgnomebt0 libgtkhtml3.8-15 libhal-storage1 libhal1 libisc11 libisccc0 libisccfg1 libiso9660-4 libjack0.100.0-0 libkrb53 liblame0 liblwres9 libmagic1 libmagick9 libmetacity0 libmjpegtools0c2a libmodplug0c2 libmono-data-tds1.0-cil libmono-security1.0-cil libmono-sharpzip0.84-cil libmono-sqlite1.0-cil libmono-system-data1.0-cil libmono-system-web1.0-cil libmono1.0-cil libmpeg2-4 libmultisync-plugin-backup libmultisync-plugin-evolution libmyspell3c2 libnautilus-burn4 libnspr4 libnss3 liboggflac3 libopenobex1 libpanel-applet2-0 libpng12-0 libportaudio2 libpostproc0d libpq5 libpulse0 libqt3-mt libqt4-core libqt4-gui libquicktime0 librapi2 librapi2-tools libslab0 libsmbclient libstlport4.6c2 libsvga1 libsynce0 libvlc0 libwxbase2.6-0 libwxgtk2.6-0 libxine-extracodecs libxine-main1 libxine1 libxine1-ffmpeg libxmlsec1 libxmlsec1-nss libxmlsec1-openssl libxvidcore4 libzzip-0-12 linux-headers-2.6.20-16 linux-headers-2.6.20-16-generic linux-headers-generic linux-image-2.6.20-16-generic linux-image-generic mesa-utils metacity metacity-common mindi mindi-busybox mjpegtools mondo mozilla-mplayer mozilla-plugin-vlc mpg123-alsa mplayer multisync mysql-client-5.0 mysql-server-5.0 nautilus-cd-burner openoffice.org openoffice.org-base openoffice.org-calc openoffice.org-common o...

Read more...

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: Confirmed → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers