could not calculate the upgrade

Bug #154576 reported by Buttay on 2007-10-19
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

during an upgrade from feisty to gutsy, the following problem occurs:

"Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report."

Then the upgrade stops.

Buttay (cyril-buttay) wrote :
Buttay (cyril-buttay) wrote :
Buttay (cyril-buttay) wrote :
Buttay (cyril-buttay) wrote :

after the update manager exited, the following line was added to main.log:

2007-10-19 22:01:18,969 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Randy Winchester (randy) wrote :

Same here:

Can't install 'ubuntu-desktop'

It was impossible to install a required package. Please report this as a bug

Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

Randy Winchester (randy) wrote :
Randy Winchester (randy) wrote :
Randy Winchester (randy) wrote :
allin (cottrell) wrote :

And me too:

A unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the
files in /var/log/dist-upgrade/ in the bugreport.

I'm attaching main.log; if other files are wanted, please say.

allin (cottrell) on 2007-10-20
Changed in update-manager:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 46245, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

My fault it's no longer a duplicate of 46245.

From main.log:
2007-10-19 22:01:18,969 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: Confirmed → Incomplete

On Wed, 19 Nov 2008, Jean-Baptiste Lallement wrote:

> Thank you for taking the time to report this bug and helping to
> make Ubuntu better. You reported this bug a while ago and there
> hasn't been any activity in it recently. We were wondering is
> this still an issue for you? Can you try with latest Ubuntu
> release? Thanks in advance.

It's not an issue for me any more. I can't recall now exactly
what the fix was -- I think I had to delete some problematic
package(s) on the old Ubuntu system to get the upgrade to work.

However, "Can you try with latest Ubuntu release?" is not really
the right question since the problem was precisely that I could
not upgrade!

(BTW, I know how difficult it is to make a full-scale, in-place
update work flawlessly, and I'm very impressed with how well it
does work under Ubuntu.)

--
Allin Cottrell
Department of Economics
Wake Forest University

Thanks for following up and sorry if the boilerplate message is not always appropriate. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers