package update-manager 1:0.81 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed

Bug #154293 reported by pholynyk on 2007-10-19
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Just before, the Restricted-Manager had crashed... but I did not report it unfortunately

ProblemType: Package
Architecture: i386
Date: Fri Oct 19 06:39:33 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: ErrorMessage: SystemError in cache.commit(): installArchives() failed

NonfreeKernelModules: nvidia
Package: update-manager 1:0.81
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.81 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed
Uname: Linux Cube 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

pholynyk (pholynyk) wrote :
pholynyk (pholynyk) wrote :

Here is the dist-upgrade log. I can start old Feisty - it sortof works, display card not detected, USB drives won't mount, but gftp and tar work OK...

pholynyk (pholynyk) wrote :
Download full text (3.4 KiB)

I did the re-upgrade script attached below...

I now seem to be mostly upgraded, but I Just noticed that I have a mix of 2.18 and 2.20 gnome packages: -core and -desktop environment seem to be old. Is this a problem? If so, how can I recover?

phil@Cube:~$ dpkg --list gnome*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===================================-===================================-======================================================================================
ii gnome-about 1:2.20.1-0ubuntu1 The GNOME about box
ii gnome-accessibility-themes 2.20.0-0ubuntu1 accessibility themes for the GNOME 2 desktop
un gnome-admin <none> (no description available)
ii gnome-alsamixer 0.9.7~cvs.20060916.ds.1-1 ALSA sound mixer for GNOME
ii gnome-app-install 0.4.13-0ubuntu1 GNOME Application Installer
ii gnome-applets 2.20.0-0ubuntu1 Various applets for GNOME 2 panel - binary files
ii gnome-applets-data 2.20.0-0ubuntu1 Various applets for GNOME 2 panel - data files
un gnome-apt <none> (no description available)
un gnome-audio <none> (no description available)
ii gnome-backgrounds 2.20.0-0ubuntu1 a set of backgrounds packaged with the GNOME desktop
ii gnome-bluetooth 0.9.1-0ubuntu1 GNOME Bluetooth tools.
ii gnome-btdownload 0.0.28-1 Gnome interface for 'executing' BitTorrent files
un gnome-card-games <none> (no description available)
ii gnome-cards-data 1:2.20.1-0ubuntu1 data files for the GNOME card games
ii gnome-control-center 1:2.20.1-0ubuntu1 utilities to configure the GNOME desktop
ii gnome-core 1:2.18.3ubuntu2 The GNOME Desktop Environment -- essential components
un gnome-cpufreq-applet <none> (no description available)
rc gnome-cups-manager 0.31-3ubuntu5 CUPS printer admin tool for GNOME
un gnome-dbg <none> (no description available)
ii gnome-desktop-data 1:2.20.1-0ubuntu1 Common files for GNOME 2 desktop apps
ii gnome-desktop-environment 1:2.18.3ubuntu2 The GNOME Desktop Environment
ii gnome-doc-utils 0.12.0-0ubuntu1 a collection of documentation utilities for the Gnome project
ii...

Read more...

pholynyk (pholynyk) wrote :

I'm still having problems with the restricted drivers manager and the nvidia driver --- it seems the nvidia-kernel module isn't loaded according to the xorg log

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add all the files contained in /var/log/dist-upgrade/ to your bug report as separate attachments? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
pholynyk (pholynyk) wrote :

Well, I had attached the tgz of the dir above, but oh, well...

BTW, I got on with it by copying home to an external HD, and doing a clean install.

pholynyk (pholynyk) wrote :
pholynyk (pholynyk) wrote :
pholynyk (pholynyk) wrote :

This is the last of them. Sorry about the delay, it's been a busy weekend.

Hope this helps.

Phil O

Changed in update-manager:
status: Incomplete → Confirmed

The cause of the failure was
=====
ERROR IOError in cache.commit(): 'Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-dev_2.6.1-1ubuntu9_i386.deb Could not connect to archive.ubuntu.com:80 (91.189.89.6), connection timed out [IP: 91.189.89.6 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gstreamer0.10/libgstreamer0.10-0_0.10.14-1ubuntu3_i386.deb Connection timed out [IP: 91.189.88.43 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-platform_3.2.2-3ubuntu3_i386.deb Connection timed out [IP: 91.189.88.43 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/libswt3.2-gtk-java_3.2.2-3ubuntu3_i386.deb Connection failed [IP: 91.189.89.6 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/l/ladspa-sdk/ladspa-sdk_1.1-6_i386.deb Connection timed out [IP: 91.189.88.43 80]
=====

This was caused by a network error. We are closing this report because it is not a bug in Ubuntu. Don't hesitate to reopen if it's still an error (despite the age of the report).

Thanks for your time and don't hesitate to submit any new bug.

Changed in update-manager:
status: Confirmed → Invalid

Was it that obvious, that I didn't notice? It's been so long, and I
ended up doing a clean-install of Ubuntu. Apologies for wasting any
time, and I am running Ubuntu 8.04 i386 just fine these days! Thank you.

-Pete

Jean-Baptiste Lallement wrote:
> The cause of the failure was
> =====
> ERROR IOError in cache.commit(): 'Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-dev_2.6.1-1ubuntu9_i386.deb Could not connect to archive.ubuntu.com:80 (91.189.89.6), connection timed out [IP: 91.189.89.6 80]
> Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gstreamer0.10/libgstreamer0.10-0_0.10.14-1ubuntu3_i386.deb Connection timed out [IP: 91.189.88.43 80]
> Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-platform_3.2.2-3ubuntu3_i386.deb Connection timed out [IP: 91.189.88.43 80]
> Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/libswt3.2-gtk-java_3.2.2-3ubuntu3_i386.deb Connection failed [IP: 91.189.89.6 80]
> Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/l/ladspa-sdk/ladspa-sdk_1.1-6_i386.deb Connection timed out [IP: 91.189.88.43 80]
> =====
>
> This was caused by a network error. We are closing this report because
> it is not a bug in Ubuntu. Don't hesitate to reopen if it's still an
> error (despite the age of the report).
>
> Thanks for your time and don't hesitate to submit any new bug.
>
> ** Changed in: update-manager (Ubuntu)
> Status: Confirmed => Invalid
>
>

--
Pete Coe
Stormtrooper TK471 (TK-0471 - 501st registered)
Great Lakes Garrison
501st Legion
www.greatlakesgarrison.com
www.501st.com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers