Download speed displayed as 'unknown' in update manager for the first seconds

Bug #152412 reported by Ryan Prior on 2007-10-13
6
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

While downloading updates, the Gutsy update manager says "Download speed: unknown" instead of showing the download speed.

Thanks for the bug report.

update-manager sometimes does not display the download speed on smaller files. Did you notice this during a distribution upgrade (meaning many big packages)?

Ryan Prior (ryanprior) wrote :

The download was a fairly small one - it took about 10 seconds to complete. Perhaps that isn't sufficient time to gauge the download speed? If that is so, the "download speed" should show something other than "unknown", or should just not show up at all.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What alterntive wording would you suggest instead of "unknown"? Hiding is certainly a alternative as well.

Changed in update-manager:
importance: Undecided → Low
milestone: none → later
status: New → Confirmed
Ryan Prior (ryanprior) wrote :

If it can be determined that the download will take such a short time that a download speed will not be shown, I would suggest not even showing a new dialog, but instead just have a mini-progress bar in the lower right hand corner of the window a la File Roller. In that case the user doesn't need to know that there is a download going on because it's all over very quickly and there isn't any download speed that would be displayed anyway. If it's going to take more time, they might appreciate a progress dialog that displays the download speed and a large progress bar, etc.

Draqu (draqu03) wrote :

Guys about this... update manager. Dunno if it's the right topic but i searched on google and found this. My download speed on Mozzila is between 200 - 800 kb/s but in update manager and the rest of linux official downloads it allways show me in bites :| it's between 200 b/s and 700 b/s it doesn't just show... that's the download speed. Any ideea why ? Or may it be a bug ? <email address hidden> pls send an email if someone knows something. Thank You !

Michael Vogt (mvo) on 2008-12-16
Changed in update-manager:
milestone: later → none
Sebastien Bacher (seb128) wrote :

unknown is usually being displayed during a short time required to do the speed calculation (you need to collect some datas to be doing that), doesn't seem really an hundredpapercut issue

Ryan Prior (ryanprior) wrote :

If I have my system monitor open as I begin a download, it immediately registers a change in my bandwidth usage when the download begins. Surely the display could use the same information that the system monitor can use and display a download speed rating.

I understand that it would be nice to wait for a few seconds before displaying an ETA, since those tend to fluctuate at first. However, I don't see the reason not to indicate immediately that the files are indeed downloading using whatever information is immediately available.

I'd say I disagree. Better 'unknown' for a bit (if its long, it'll come up
quite soon enough) than bouncing and blinking numbers.

Not that many care about them to begin with - they're just an indication of
progress, and if its fast enough, its not needed.

Mat Tomaszewski (mat.t.) wrote :

Doesn't seem like an issue worth investing development time as part of the papercut project

Changed in hundredpapercuts:
status: New → Invalid
Robert Roth (evfool) wrote :

I have tried to reproduce this on Natty, and it seems that Natty doesn't show any download speed estimation in the first seconds, only shows it after 3-4 seconds (after it gets a meaningful estimation of the download speed), so I will close this bug with Fix Released. Feel free to reopen this if you think that this is still a valid bug, and please provide a suggested solution other then the one currently implemented.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers