package update-manager 1:0.76 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:I wasn't able to locate file for the libc6 package. This might mean you need to manually fix this package.

Bug #149872 reported by rrr0321 on 2007-10-06
8
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Installed Gutsy Beta 1 and this is the first upgrade.

ProblemType: Package
Architecture: i386
Date: Sat Oct 6 09:58:32 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:I wasn't able to locate file for the libc6 package. This might mean you need to manually fix this package.

NonfreeKernelModules: nvidia
Package: update-manager 1:0.76
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.76 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:I wasn't able to locate file for the libc6 package. This might mean you need to manually fix this package.
Uname: Linux rich-desktop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

rrr0321 (rrroszak) wrote :
Michael Vogt (mvo) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bugreport as attachments to your bug report? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
rrr0321 (rrroszak) wrote :

Log files from '/var/log/dist-upgrade/ attached.

Michael Vogt (mvo) wrote :

Thanks for your log files.

Could you please please attach the output of:
$ ls -l /var/cache/apt/archives/*libc6*

rrr0321 (rrroszak) wrote :

Output as below.
 ls -l /var/cache/apt/archives/*libc6*
-rw-r--r-- 1 root root 4183264 2007-09-30 21:03 /var/cache/apt/archives/libc6_2.6.1-1ubuntu9_i386.deb
-rw-r--r-- 1 root root 1147826 2007-09-30 21:03 /var/cache/apt/archives/libc6-i686_2.6.1-1ubuntu9_i386.deb

Michal Bogusz (nebeli) wrote :

aptitude upgrade fixed problem
I'm waiting for next update to check if update-manager will works

Paul Dufresne (paulduf) wrote :

Thanks, as you have given requested info, I am confirming this bug.

Changed in update-manager:
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up. I'm closing this report due to michael bogusz's last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers