update-manager crashed with ImportError in module>()

Bug #149837 reported by René Brandenburger on 2007-10-06
344
This bug affects 49 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

crash happened after applying all upgrades and rebooting the machine

ProblemType: Crash
Architecture: i386
Date: Sat Oct 6 08:32:26 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: fglrx
Package: update-manager 1:0.80
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager --dist-upgrade
ProcCwd: /home/rbrandenburger
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=de_LU.UTF-8
PythonArgs: ['/usr/bin/update-manager', '--dist-upgrade']
SourcePackage: update-manager
Title: update-manager crashed with ImportError in <module>()
Uname: Linux debberlein 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686 GNU/Linux

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please check if you have the package python-vte installed? Does the crash go away if you run:
$ sudo apt-get install --reinstall python-vte

thanks,
 Michael

Changed in update-manager:
status: New → Incomplete

OK, did a

$ sudo apt-get install --reinstall python-vte

update-manager works fine after reboot. To get the same situation as when the crash happened, i need to wait untill the update-manager asks me to reboot and I initiate a reboot by clicking on the symbol of the update-manager in the notification area. Is there an easy way to let the update-manager request a reboot?

Michael Vogt (mvo) wrote :

The easiest way for this is to:
$ sudo touch /var/run/reboot-required ; sudo /var/lib/update-notifier/dpkg-run-stamp

fine, no crash this time, tried it several times

Michael Vogt (mvo) wrote :

Thanks for this additional inforrmation.

If you could attach /var/log/apt/term.log, that would be nice. I wonder if pycentral did something wrong during the python-gtk installation.

here is the term.log, if you need an older one, i can supply it too

Richie Ward (richies) wrote :

This would be hard to reproduce but i got this after first full upgrade on Ubuntu Hardy Alpha 1

Most recent comment says this still occasionally occurs in Hardy. Setting status to confirmed

Changed in update-manager:
status: Incomplete → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are closing this report because you reported this bug a while ago and there is no recent duplicate nor user mentioning having the issue on Intrepid. If this is still an issue, don't hesitate to reopen the report. Thanks again!

Changed in update-manager:
status: Confirmed → Invalid

Well, i'm guessing the problem got fixed somehow. Thanks.

On Mon, Dec 1, 2008 at 6:46 PM, Jean-Baptiste Lallement <
<email address hidden>> wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. We are closing this report because you reported this bug
> a while ago and there is no recent duplicate nor user mentioning having
> the issue on Intrepid. If this is still an issue, don't hesitate to
> reopen the report. Thanks again!
>
> ** Changed in: update-manager (Ubuntu)
> Status: Confirmed => Invalid
>
> --
> update-manager crashed with ImportError in module>()
> https://bugs.launchpad.net/bugs/149837
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "update-manager" source package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: update-manager
>
> crash happened after applying all upgrades and rebooting the machine
>
> ProblemType: Crash
> Architecture: i386
> Date: Sat Oct 6 08:32:26 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/bin/update-manager
> InterpreterPath: /usr/bin/python2.5
> NonfreeKernelModules: fglrx
> Package: update-manager 1:0.80
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager --dist-upgrade
> ProcCwd: /home/rbrandenburger
> ProcEnviron:
> SHELL=/bin/bash
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
> LANG=de_LU.UTF-8
> PythonArgs: ['/usr/bin/update-manager', '--dist-upgrade']
> SourcePackage: update-manager
> Title: update-manager crashed with ImportError in <module>()
> Uname: Linux debberlein 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT
> 2007 i686 GNU/Linux
>

--
As Always,

 Philip Wynn Royer

Dylan Taylor (dylanmtaylor) wrote :

This bug just occured to me on the restart after upgrading Ubuntu 8.04 to 8.10 - haven't had recurrences yet.

jerrylamos (jerrylamos) wrote :

Just happened today here on jaunty updated to beta. Tried to do an update and crash it went. Attached is what was in /var/crash.

Jerry

Saul (creative-balm) wrote :

Running Maverick - problem appears to arose from last update (issued yesterday?) which was specifically for Up Date Manager

Bug,

I'd like to add you to my professional network on LinkedIn.

- Philip Royer

Philip Royer
CEO at Zipkon

Confirm that you know Philip Royer
https://www.linkedin.com/e/-ac8ina-gigqcwxz-20/isd/2080127550/jOo5o6ad/EML-invite_guest_no_snack_59/

(c) LinkedIn 2010

HAL kr LOWEEN SA pua LES!
EVERYTHING YOU NEED for a great and exciting day you can buy HERE!
Only TODAY ANY GOODS you can get with a next code 4437 which gives you a 40% dis jh count.
Be prepared for a scary day and make a show!

Get the great di dal scou be nts on popular so hn ft lv wa etj re today at www.greatrivercityone.com.ua
All s oq of xwx wa za re is instantly available to do vuc wnl pf oad - No Need Wait!
ALL OUR SO xkx FTW nkm ARE bs S ON ALL EUROPEAN LANGUAGES -
USA, English, France, Italy, Spanish, German and more!!!

SO kw FTW wf ARE:Windows 7 Ultimate 32 bit99.95Windows 7 Ultimate 64 bit99.95Windows XP Professional with Service Pack 369.95Office Professional Plus 2010 32-bit89.95Office Professional Plus 2010 64-bit89.95Adobe Photoshop CS5.1 Extended99.95Office Professional 200769.95Adobe Acrobat 9 Pro Extended59.95Office Home and Student 200749.95
Also we have so mu lx ch s pk of qe t for MA pg CIN cp TO phv SH!!!Adobe Creative Suite 5.5 Master Collection for MAC269.95Adobe Creative Suite 5.5 Design Premium for MAC219.95Microsoft Office 2008 Standart Edition for MAC119.95Aperture 3 for MAC79.95Adobe Photoshop CS5.1 Extended for MAC89.95
To re gbd vi qj ew full list of the offers, v cvi is qvi it www.greatrivercityone.com.ua

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers