If update-manager -d fails, you can't try again

Bug #149203 reported by Robin Sheat on 2007-10-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

I tried updating to Gutsy beta, and didn't have enough free space. So I freed space, and tried 'update-manager -d' again. This time, it didn't notify me of the ability to upgrade. Eventually I found that an 'aptitude update' made it work, but this is something that could trip people up.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What version of update-manager where you using? It should offer the feature to show it again, if it does not that is a bug.

Changed in update-manager:
status: New → Incomplete
Robin Sheat (eythian) wrote :

As far as I can find out from poking through dpkg.log file, 1:0.59.25 - this is what was in feisty when I ran the upgrade.

Changed in update-manager:
importance: Undecided → Medium
status: Incomplete → Confirmed
Saurabh Rindani (saurabh-prl) wrote :

I have the same problem.

I had the same problem with the previous version of update-manager, and even after the very recent update of the update-manager to 1:0.59.26.

Saurabh Rindani (saurabh-prl) wrote :

As written earlier, I had a problem with upgrade from 7.04 to 7.10 using update-manager because of not enough free space. After that I could not get update-manager to give me the option to upgrade to 7.10.

I have the following further information:

I found that I could get update-manager (in feisty) to show the option to upgrade, after copying the correct meta-release file (obtained from changelogs.ubuntu.com) under

.update-manager-core/

and

/var/lib/update-manager/

(I had to be careful that the network proxy setting was correct -- setting network proxy for direct connection instead of the correct server ip address led to these files being replaced by html error messages).

However, on clicking on the upgrade button, the upgrade fails, and update-manager hangs. If I had used update-manager -c from a terminal, the message is:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/UpdateManager/UpdateManager.py", line 914, in on_button_dist_upgrade_clicked
    fetcher.run()
  File "/usr/lib/python2.5/site-packages/UpdateManager/Core/DistUpgradeFetcherCore.py", line 153, in run
    if not self.showReleaseNotes():
  File "/usr/lib/python2.5/site-packages/UpdateManager/DistUpgradeFetcher.py", line 79, in showReleaseNotes
    release_notes = urllib2.urlopen(uri)
  File "/usr/lib/python2.5/urllib2.py", line 121, in urlopen
    return _opener.open(url, data)
  File "/usr/lib/python2.5/urllib2.py", line 366, in open
    protocol = req.get_type()
  File "/usr/lib/python2.5/urllib2.py", line 241, in get_type
    raise ValueError, "unknown url type: %s" % self.__original
ValueError: unknown url type:
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 91, in <module>
    app.main(options)
  File "/usr/lib/python2.5/site-packages/UpdateManager/UpdateManager.py", line 1017, in main
    gtk.main()
KeyboardInterrupt

Rolf Leggewie (r0lf) wrote :

FWIW, I don't see this. Are people still affected by this issue in the later releases?

Changed in update-manager (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Rolf Leggewie (r0lf) wrote :

Robin, Saurabh? Is this still an issue for you guys?

Will close the ticket shortly if there are no further confirmations

Thanks for pursuing this issue.

The point is that once I succeeded (by some means) in upgrading, there
was no reason to go back and do the whole thing again. Nevertheless, it
might be useful to someone if the details are recorded somewhere.

Could you please give me a little time to check earlier exchanges of
mails with someone (I do not think they were with you) and give you a
summary. I cannot say anything from memory!

Thanks.

Saurabh
_________________________________________________________________________

On Thu, 8 Apr 2010, Rolf Leggewie wrote:

> Robin, Saurabh? Is this still an issue for you guys?
>
> Will close the ticket shortly if there are no further confirmations
>
> --
> If update-manager -d fails, you can't try again
> https://bugs.launchpad.net/bugs/149203
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Robin Sheat (eythian) wrote :

I'm not sure. When I upgraded to Lucid beta, I had enough free space, so the issue didn't come up. An easy way to check would be to fire up a Karmic VM, fill it almost up, and try upgrading.

Dillinger (cyril-cber) wrote :

je ne m'en sort toujours pas,merci de votre aide:
Message d’erreur:
'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/fr.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

Changed in update-manager (Ubuntu):
assignee: Rolf Leggewie (r0lf) → Dillinger (cyril-cber)
papukaija (papukaija) wrote :

@Dillinger: That error message is caused by bug 346386 which is fixed in Natty and newer.

Changed in update-manager (Ubuntu):
assignee: Dillinger (cyril-cber) → papukaija (papukaija)
assignee: papukaija (papukaija) → nobody
Dillinger (cyril-cber) wrote :

j'ai essayé toute les solution, mais toujours pas de résultat.
je possède un pc Acer Aspire 7720z:
lorsque je veut faire une mise a jour le message de bug et le suivant:
Un problème irrémédiable est survenu pendant l'initialisation des informations du paquet.

Veuillez signaler ce bogue du paquet « update-manager » en y joignant le message d'erreur suivant :

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/fr.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.'
Ensuite lorsque je veut graver un dvd video il me manque"Dvd author"
 depuis que j'ai fais la mise a niveau depuis mon pc de l a vertion 10.10 à 11.04 ,tout ces problèmes son survenu.
Je ne peut plus non plus utiliser la logithèque,elle tourne dans le vide sans sarrette.
De plus,je ne peut plus entrer dans mon bios,un mot de passe m'est demandé,alors que je n'en ai installé aucun,donc je ne peut pas installé manuellement de système d'exploitation, quel qu’il soit.
Et comme la précédente version d'ubuntu fonctionnai parfaitement,j'avais désinstallé windows.
Je suis donc dans une impasse,si quelqu’un peut m'aider,je lui en serais très reconnaissant!

peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers