upgrade from feisty to gutsy beta errors

Bug #147758 reported by TimArbuckle on 2007-10-01
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

My laptop is a compaq nx9110 and was running Feisty. Decided to upgrade to Gutsy beta using
    gksudo "update-manager -c -d".
Started the process on Friday afternoon and let it run all weekend (at work). Came in monday to the following errors:

something about these (only wrote down package names)
    /var/cache/apt/archives/launchpad-integration_0.1.14_all.deb
    /var/cache/apt/archives/python-apt_0.7.3.1ubuntu1_i386.deb

then
    kdelibs4.20 dependency problem - leave unconfigured
    python-apt dependency problem - leave unconfigured

Booting off newest kernel (2.6.22-12-generic) gives:
    Kernel panic - not syncing VFS: unable to mount root fs on unknown block(0,0)

I am able to use both 2.6.20-15-generic and 2.6.20-16-generic -- they have same grub config as 2.6.22-12-generic.

When logging in I get "Failed to initialize HAL!"

I have no networking, audio, etc. Laptop uses atiixp, kernel modules are loaded. I have tried
    sudo /etc/init.d/hal.dpkg-new restart
that does not help.

Attempting manual "sudo dhclient3 eth0" results in numerous "Permission denied" and "Operation not permitted" messages and still no network access. The script is looking for /etc/samba/dhcp.conf.new which does not exist.

Also "command-not-found" gives the KABOOOM!! message about "command-not-found has crashed".

Attempted to used compiz -- will not allow me.

Attempted to use "Appearance Preferences". Was able to change "Theme" but other tabs result in unresponsive dialog with 100% cpu usage.

I will backup log files under /var/log/dist-upgrade and dmesg if you would like them sometime later.
Hope this is helpful.

Marco Rodrigues (gothicx) wrote :

Please attach here the files in /var/log/dist-upgrade

Changed in update-manager:
importance: Undecided → Low

Attached is an archive file containing

the dist-upgrade folder
a list of files in /boot
the output from dmesg
the grub menu.lst file
the ubuntu-files is a list of all installed packages before doing the
upgrade

On 10/1/07, Marco Rodrigues <email address hidden> wrote:
>
> Please attach here the files in /var/log/dist-upgrade
>
> ** Changed in: update-manager (Ubuntu)
> Sourcepackagename: None => update-manager
>
> ** Changed in: update-manager (Ubuntu)
> Importance: Undecided => Low
>
> --
> upgrade from feisty to gutsy beta errors
> https://bugs.launchpad.net/bugs/147758
> You received this bug notification because you are a direct subscriber
> of the bug.
>

TimArbuckle (timarbuckle) wrote :

attempting "sudo aptitude update" gives

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: Couldn't rebuild package cache

running "sudo dpkg --configure -a" does not help.

Michael Vogt (mvo) wrote :

Thanks for this additional information.

Unfortunately the attachment did not make it to this report, could you please attach it via the web interface?

Thanks,
 mIchael

TimArbuckle (timarbuckle) wrote :

here is the attachment
btw i reinstalled feisty on my laptop then from a clean install did a gutsy upgrade -- similar problems.

I was able to do a fresh install of gutsy on my laptop and after 2 days of tweaks i have most everything working. Sound was a problem (still not quite right but functional), still don't have the touchpad working. Screens and Graphics utility repeatedly crashes when i try to enable a second monitor.

Changed in update-manager:
status: New → Confirmed
to be removed (liw) wrote :

It looks to me, from a quick analysis of the log files, that this was a temporary problem with some packages in the beta version of gutsy. The bug has no duplicates, and there doesn't seem to be other similar bugs open. Thus, I suspect it was fixed since.

to be removed (liw) wrote :

Since Michael Vogt agreed on IRC with my analysis, I'll close the bug. Because the only relevant bug state Launchpad allows is "invalid", that's what I'm going to use, even though the bug certainly was valid when it was reported.

TimArbuckle, if you disagree with my analysis, please re-open the bug, or ask me, and I'll gladly do it for you. Sorry for taking a year and a half to get to it.

to be removed (liw) wrote :

Since Michael Vogt (update-manager maintainer) agreed on IRC with my analysis, I'll mark the bug as fixed. TimArbuckle, if you disagree, please change the state, or ask me, and I'll gladly do it for you.

Changed in update-manager:
status: Confirmed → Fix Released
TimArbuckle (timarbuckle) wrote :

great, thanks

Lars Wirzenius wrote:
> Since Michael Vogt (update-manager maintainer) agreed on IRC with my
> analysis, I'll mark the bug as fixed. TimArbuckle, if you disagree,
> please change the state, or ask me, and I'll gladly do it for you.
>
> ** Changed in: update-manager (Ubuntu)
> Status: Confirmed => Fix Released
>
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers