UpdateManager crash on upgrade to Gutsy

Bug #146650 reported by Ales Katona on 2007-09-29
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
djvulibre (Ubuntu)
Undecided
Unassigned
enigma (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

After downloading all .deb files and updating most of them, the update-manager stopped with some errors. Gutsy is working tho, so most things probably made it.

Here are some translated end parts of logs (original files from /var/log/dist-upgrade added as attachment):

--------------------------------term.log--------------------------------------
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.22-12-386
Errors during processing:
 enigma-data
 enigma
 libdjvulibre15
 evince
 ubuntu-desktop
Traceback (most recent call last):
  File "logging/__init__.py", line 753, in emit
  File "logging/__init__.py", line 731, in flush
IOError: [Errno 9] Bad file descriptor
/usr/share/apport/apport-gtk:40: GtkWarning: Failed to set text from markup due to error parsing markup: Chyba na riadku 1 znak 56: '<' nie je platný znak po koncovom mene elementu 'big'. Povolený znak je '>'
  'apport-gtk.glade'))
gutsy: Fatal IO error 9 (Bad file descriptor) on X server :0.0.

--------------------------------apt.log--------------------------------------

Installing xsane as dep of ubuntu-desktop
Setting NOT as auto-installed because its a direct dep of a package in section metapackages
Installing xsane-common as dep of xsane
/tmp/tmpboT5RT/DistUpgradeViewGtk.py:305: Warning: g_io_add_watch_full: assertion `channel != NULL' failed
  gtk.main_iteration()
/usr/share/apport/apport-gtk:40: GtkWarning: Failed to set text from markup due to error parsing markup: Error on line 1 char 56: '<' is not a valid character after ending name of element 'big'. Allowed character is '>'
  'apport-gtk.glade'))
/tmp/tmpboT5RT/DistUpgradeViewGtk.py:325: Warning: g_source_remove: assertion `tag > 0' failed
  gtk.main_iteration()

Ales Katona (almindor) wrote :
Ales Katona (almindor) wrote :

Chyba na riadku 1 znak 56: '<' nie je platný znak po koncovom mene elementu 'big'. Povolený znak je '>'

is translated as:

Error on line 1 char 56: '<' is not a valid character after ending name of element 'big'. Allowed character is '>'

Changed in update-manager:
importance: Undecided → High
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport. Please attach the files in /var/log/dist-upgrade/* to this report. Thanks, Michael

Changed in update-manager:
status: Confirmed → Incomplete
Michael Vogt (mvo) wrote :

Oh, sorry. I just noticed that the logs are attached. My bad.

THanks,
 Michael

Changed in update-manager:
status: Incomplete → Confirmed
Michael Vogt (mvo) wrote :

The package 'enigma-data' seems to cause this:

Nastavujem balík enigma-data (1.01-1ubuntu1) ...
The generated cache was invalid.
dpkg: chyba pri spracovávaní enigma-data (--configure):
 podproces post-installation script vrátil chybový kód 1
dpkg: problémy so závislosťami zabránili konfigurácii balíku enigma:
 enigma závisí na enigma-data (= 1.01-1ubuntu1); aj keď:
  Balík enigma-data ešte nie je nakonfigurovaný.

Michael Vogt (mvo) wrote :

And 'libdjvulibre15' gives trouble too:

Nastavujem balík libdjvulibre15 (3.5.19-2ubuntu1) ...
dpkg: chyba pri spracovávaní libdjvulibre15 (--configure):
Nastavujem balík libkpathsea4 (2007-12ubuntu3) ...
Nastavujem balík libpoppler2 (0.6-0ubuntu1) ...
dpkg: problémy so závislosťami zabránili konfigurácii balíku evince:
 evince závisí na libdjvulibre15 (>= 3.5.19); aj keď:
  Balík libdjvulibre15 ešte nie je nakonfigurovaný.

Dio (dio) wrote :

I had this bug during the installation of the Gusty RC, there is my /var/log/dist-upgrade/apt.log if it can help.

This happened to me with gutsy final. I seem to have a half installed system. Most seems to be there but the configure process was about half way through so X won't start for example (and failsafe X complains about incorrect parameters).

dist-upgrade logs attached.

Léa GRIS (lea-gris) wrote :

Upgrading from Feisty to Gutsy final using a verified ok DVD gave this :

"Impossible d'installer « /media/cdrom0//pool/main/e/evince/evince_2.20.0-0ubuntu3_i386.deb »

La mise à jour va continuer mais le paquet « /media/cdrom0//pool/main/e/evince/evince_2.20.0-0ubuntu3_i386.deb » risque de ne pas être opérationnel. Vous devriez envoyer un rapport de bogue à propos de ce paquet.

ne peut pas accéder à l'archive"

Unable to install « /media/cdrom0//pool/main/e/evince/evince_2.20.0-0ubuntu3_i386.deb »

The upgrade will continue but the packet « /media/cdrom0//pool/main/e/evince/evince_2.20.0-0ubuntu3_i386.deb » may not be operational.
You should send a bug report about this package.

can't access the archive.

TerryG (tgalati4) wrote :

Marking as Confirmed. Bug is being tracked in update-manager.

Changed in enigma:
status: New → Confirmed
TerryG (tgalati4) wrote :

Marked as Confirmed. Bug is being tracked in update-manager.

Changed in djvulibre:
status: New → Confirmed

As Michael said, the failure is caused by enigma-data and libdejavu15. This is not a bug in update-manager.
BTW this bug has been reported a while ago, is it still an issue ?

Changed in update-manager:
status: Confirmed → Invalid
Dimitrios Symeonidis (azimout) wrote :

No new reports on upgrading djvulibre, marking as fix released there.

Anyone has this problem with enigma? Please come forward...

Changed in djvulibre (Ubuntu):
status: Confirmed → Fix Released
Changed in enigma (Ubuntu):
status: Confirmed → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers