Ubuntu

Could not calculate the upgrade

Reported by Juan Pablo Salazar Bertín on 2007-09-29
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

update-manager offered a distro upgrade. Then in got the following message:

Could not calculate the upgrade
A unresolvable problem occurred while calculating the upgrade.
Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 28 20:06:35 2007
DistroRelease: Ubuntu 7.10
Package: update-manager 1:0.78
PackageArchitecture: all
SourcePackage: update-manager
Uname: Linux snifer-laptop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

This is the only file in /var/log/dist-upgrade/

Confirmed in bug #146538

Changed in update-manager:
status: New → Confirmed
Nanley Chery (nanoman) wrote :

Strange. I have this problem also in the Gutsy Beta as well. I have no clue what it could be upgrading to.

syg00 (sginnane) wrote :

Add another occurrence. AMD64, clean install - trying to finish install by updating latest packages.
Very similar apt-log.

Kansei (clauretano) wrote :

Confirmed on Gutsy (was originally installed during Tribe 1 times) AMD64

Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

I was offered a partial upgrade this morning, ran it, computer was fine since then (through reboots even). Just got the update notification again, now this error.

Kansei (clauretano) wrote :

Running (as root)

aptitude update

then

aptitude safe-upgrade

seems to work around it. I was able to check for updates and it is now downloading and installing them.

Kansei (clauretano) wrote :

Whatever you guys do, don't run a dist-upgrade through aptitude.

It showed 4 unresolved dependencies. To 'fix' the first one, the 'ubuntu-desktop' metapackage has to be removed, as well as a couple others. Run dist-upgrade again, it wants to remove pidgin, udev, etc.. run it again, and it wants to remove over 500 packages on the system, including everything xorg and gnome-related in any way.

Kansei (clauretano) wrote :

This fixed it for me:
-Run synaptic
-"Refresh" to pull package lists
-"Mark all upgrades"
-search for any packages you know got removed by a dist-upgrade if you ran it. For me, I told it to reinstall pidgin, AccessGrid, and ubuntu-desktop (which installed two other trivial packages).
-"Apply"

Nanley Chery (nanoman) wrote :

I did not change any settings and the problems fixed itself. I updated today, and I wasn't notified for a dist upgrade, just the usual regular updates.

McCown (steven-mccown) wrote :

I had the same problem and just fixed it. A while ago, I had installed Ubuntu (GNOME) 7.07 and then used synaptic to also install kubunutu-desktop (KDE). This gave me the use of most of the KDE apps while running GNOME. Kind of neat.

During the upgrade, I discovered that my Gutsy Alternate CD for Ubuntu (GNOME) didn't have the upgrade packages for kubuntu-desktop (duh). Since I had told the installer not to download new updates, it was having a problem proceeding with a gutsy upgrade while a feisty kubunutu-desktop remained.

My solution was to let the alternate cd go online to download the required packages that weren't on my cd. This way, everything upgrades and the conflict goes away.

Another solution would likely have been to uninstall kubuntu-desktop using synaptic.

Hope this helps...

McCown (steven-mccown) wrote :

Sorry, that was Ubuntu 7.04 -- I don't want to introduce more confusion...

Layne (retnuh66) wrote :

Could you please attach your sources.list?

santosh (mandumulasantosh) wrote :

 got a problem, 2 days back i was trying to install medibuntu repositories, from the command line
and from software sources(from third party software), typed in this command
sudo wget http://www.medibuntu.org/sources.list.d/gutsy.list -O /etc/apt/sources.list.d/medibuntu.list,
there is some thing like this to download from third party software started with .deb,
I typed that APT line and clicked ADD SOURCE button, and then it came up with an error message

E: Type '--16:53:40--' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list
E: The list of sources could not be read.
Go to the repository dialogue to correct the problem.
E: _cache->open() failed, please report.
And then after i realised my source list got corrupted, resulting am unable to access synaptic manager, update manager.
How do i get back to normal, How can i access back to synaptic manager, update manager,

could anyone pls help me
Am desperate

Regards
santosh

Dimitrios Symeonidis (azimout) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in update-manager (Ubuntu):
status: Confirmed → Incomplete

I have not seen this issue since this version.

Sent from my iPhone

On Sep 5, 2009, at 6:31 AM, Dimitrios Symeonidis <email address hidden>
wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an
> issue
> for you. Can you try with the latest Ubuntu release? Thanks in
> advance.
>
> ** Changed in: update-manager (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Could not calculate the upgrade
> https://bugs.launchpad.net/bugs/146536
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Dimitrios Symeonidis (azimout) wrote :

closing as fix released, as per your last comment

Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers