Too easy to accidentally restart computer when 'restart to complete update' box pop up

Bug #1421044 reported by Chris Billington on 2015-02-12
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Brian Murray
Trusty
High
Brian Murray

Bug Description

I was typing an email whilst an update was in progress, and when the 'restart to complete update' box popped up, I accidentally restarted my computer. I'm not sure whether this took one or two taps of the spacebar, but happened from me simply continuing to type for a second or so when the box popped up.

If the box is to grab focus regardless of what the user is doing, then it needs to *not* have the 'restart now' button focused and ready for an enter key or spacebar.

It would be better if no button had focus, so that an actual click was required to take action.

What I expected to happen: Nothing, ideally. It's ok if my typing is interrupted, but nothing else should happen if I'm in the middle of typing when the box pops up.

What happened: My computer restarted.

Ubuntu version: 14.04

Related branches

description: updated
tags: added: trusty
Changed in update-manager (Ubuntu):
importance: Undecided → High
tags: added: vivid
Changed in update-manager (Ubuntu):
status: New → Triaged
Changed in update-manager (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:15.04.2

---------------
update-manager (1:15.04.2) vivid; urgency=medium

  * UpdateManager/Core/utils.py: use rpartition in case the process name
    contains the right parenthesis character. Thanks to Roman Odaisky for the
    patch. (LP: #1399916)
  * UpdateManager/Dialogs.py: set the focus to "Restart Later" instead of
    "Restart Now", so people don't accidentally reboot. (LP: #1421044)
 -- Brian Murray <email address hidden> Wed, 18 Feb 2015 11:38:56 -0800

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
Daniel Richard G. (skunk) wrote :

Hello Brian,

This issue also manifests via accidental clicking (you're about to click in a regular application window, then the dialog pops up, with the "Restart Now" button right under the pointer). Changing the default focus only addresses accidental rebooting via keyboard---and even then, will fail if the user is entering a specific arrow + Enter key sequence.

Could you have the "Restart Now" button start a thirty-second countdown, like the regular restart dialog does? Not only would this better help avoid accidental rebooting, it would be consistent behavior.

(If the "Restarting in NN seconds" dialog has a shortcut button, as some users will no doubt want, it should probably be greyed out for the first few seconds of the countdown, so that a spurious double-click doesn't cause trouble.)

k3dar7 (k3dar7) wrote :

this bug is reported for "Ubuntu version: 14.04" and is mark as fixed after fix released only for 15.04... why is not fix released also for 14.04 LTS ???

Brian Murray (brian-murray) wrote :

We first fix bugs in the development release of Ubuntu and then depending on the severity / scope of impact of the bug report we will prepare a Stable Release Update for the bug for other releases of Ubuntu. You can learn more about the Stable Release Update process at http://wiki.ubuntu.com/StableReleaseUpdates.

Daniel Richard G. (skunk) wrote :

I think this bug is pretty serious from a usability perspective, given that an unplanned reboot can result in lost data and pissed-off users. I use Trusty, and would go for the SRU.

Changed in update-manager (Ubuntu Trusty):
milestone: none → ubuntu-14.04.3
status: New → Triaged
importance: Undecided → High
Paul Crawford (psc-sat) wrote :

I agree with Daniel, having a machine randomly reboot on you because of a fault in GUI design is pretty serious, same as if the kernel occasionally panicked when you happened to be typing. Any ideas of time-scale to the patch being pushed out?

Brian Murray (brian-murray) wrote :

I'll upload an SRU for this to Trusty either this week or next. Feel free to ping me if I don't get to it.

Paul Crawford (psc-sat) wrote :

Thanks Brian, will look out for that!

Hello Chris, or anyone else affected,

Accepted update-manager into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:0.196.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in update-manager (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
Chris Billington (cjbil1) wrote :

Tested update-manager 1:0.196.13 on trusty, waited until an update happened that required a restart, and indeed the 'restart later' button had focus. Pressing spacebar dismissed the box without restarting the computer.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.13

---------------
update-manager (1:0.196.13) trusty-proposed; urgency=medium

  * UpdateManager/Dialogs.py: set the focus to "Restart Later" instead of
    "Restart Now", so people don't accidentally reboot. (LP: #1421044)
 -- Brian Murray <email address hidden> Tue, 14 Apr 2015 14:18:36 -0700

Changed in update-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Matthew Paul Thomas (mpt) wrote :

Specification updated. <https://wiki.ubuntu.com/SoftwareUpdates?action=diff&rev2=195&rev1=194> None of the buttons should be the default; accidentally dismissing the Updater, if you had just launched it manually, would be annoying too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers