Please remove all ltsp* blacklisting

Bug #1415785 reported by Alkis Georgopoulos on 2015-01-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt
Precise
High
Unassigned

Bug Description

[Impact]
Please remove all references to the ltsp-client, ltsp-client-core, ltspfs, and ltspfsd packages from the update-manager sources, as update-manager currently removes those packages on dist-upgrades, breaking LTSP installations.
Update-manager has seen a lot of changes and that blacklisting no longer exist in 14.04+, so we only need this as an SRU for 12.04.

Rationale:
Historically, the ltsp-client package had a preinst check that aborted its installation in normal systems (by checking for an /etc/ltsp_chroot file).

If someone managed to install it outside of an LTSP chroot, then dist-upgrades were broken there, and a workaround was introduced in update-manager 1:0.60 gutsy Tue, 24 Apr 2007 16:39:26 +0200.
This is mentioned in the update-manager changelog and in LP #109638.

But, since Ubuntu Precise, ltsp-client no longer has these restrictions (I'm an upstream LTSP developer) and it's even useful to have it installed in normal LTSP servers (see https://help.ubuntu.com/community/UbuntuLTSP/ltsp-pnp for more info).

Now the opposite problem arises: when there's need for `update-manager -dist-upgrade`, update-manager removes at least ltsp-client and ltspfsd, breaking LTSP installations.
See the attached update-manager screenshot.

Actual use case: a teacher is prompted for a normal update, where some packages need to be updated, and additionally some unrelated package is now obsolete and needs to be removed. In that case, update-manager starts a dist-upgrade (not to be confused with a release upgrade, it's normal maintenance, not e.g. upgrading from 12.04 to 14.04) and removes ltsp-client and ltspfsd. The LTSP server stops working and the teacher doesn't know why, he never even pressed the "expand" button in the update dialog to see that those packages were uninstalled.

[Test Case]
* Install LTSP client, for example with:
sudo apt-get install ltsp-client
* Just to make sure that your apt is in a consistent state, run:
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get purge --auto-remove
...we expect no output from these.
* Now run:
update-manager --dist-upgrade
See that update-manager prompts for ltsp-client and ltspfsd removal, mentioning they're no longer needed, as shown in the attached screenshot.

On the other hand, with the included patch, `update-manager --dist-upgrade` shouldn't mention that anything needs removal.

[Regression Potential]
Not much. In 14.04+ that blacklisting is already removed, ltsp isn't mentioned anywhere in the update-manager sources anymore.

And of course we'll be testing the package from precise-proposed in many installations (specifically, hundreds of Greek schools) before confirming that it's OK to copy it to -updates.

Alkis Georgopoulos (alkisg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
description: updated
tags: added: patch
Changed in update-manager (Ubuntu):
importance: Undecided → High
assignee: nobody → Michael Vogt (mvo)
Brian Murray (brian-murray) wrote :

This has been uploaded to the Precise queue for review by the SRU Team.

Changed in update-manager (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High

Hello Alkis, or anyone else affected,

Accepted update-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/update-manager/1:0.156.14.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

SRU Verification Precise:
I have verified that update-manager (1:0.156.14.18) in -proposed fixes the above bug and doesn't remove ltsp packages on dist-upgrades and doesn't break LTSP installations as shown in the attached screenshot..
Marking as verification done.

Thanks.

tags: added: verification-done
removed: verification-needed
Alkis Georgopoulos (alkisg) wrote :

I too verify that 1:0.156.14.18 in precise-updates fixes the issue, it doesn't prompt for ltsp-client and ltspfsd removal anymore.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156.14.18

---------------
update-manager (1:0.156.14.18) precise-proposed; urgency=low

  [ Lefteris Nikoltsios ]
  * remove all ltsp* blacklisting (LP: #1415785)

  [ Michael Vogt ]
  * improve HWE support information message in the gtk UI
    (LP: #1402706)
  * consider more meta-packages when doing the apt-get install
    suggestion (LP: #1420217)
  * show unsupported packages if no replacement packages can be found
    (LP: #1341320)
 -- Michael Vogt <email address hidden> Tue, 10 Feb 2015 17:39:22 +0100

Changed in update-manager (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Brian Murray (brian-murray) wrote :

This seems to also be fixed in ubuntu-release-upgrader, which now does release upgrades, so I am setting the update-manager task for the development release to Invalid.

Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers