Software Updater doesn't indicate all avalailable upgrades

Bug #1414557 reported by ubuntu-tester
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hello everybody,

1) My release of Ubuntu :
$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

2) The version of package I'm using : update-manager 1:0.196.12

3) What you expected to happen ? I expect to install all available upgrades when I manually launch Software Updater (update-manager).

4) What happened instead ? aptitude (and apt-get) indicates avalaible upgrades while Software Updater (update-manager) indicates no available upgrades.

My configuration of Software Updater (update-manager) :
Automatically check for updates : Daily
When there are security updates : Display immediatly
When there are other updates : Display immediatly

My configuration in dconf :
path : /com/ubuntu/update-notifier/regular-auto-launch-interval
key type : "i"
key name : "regular-auto-launch-interval"
key value : 0
summary : Interval (in days) when to auto launch for normal updates
description : The interval (in days) when auto launching update-manager for normal updates. Please note that it will auto launch for security updates immediately. If you set it to "0" it will also launch as soon as updates become available.

Tests :

2015-01-14 :
$ aptitude safe-upgrade -s
The following packages will be upgraded:
  compiz compiz-core compiz-gnome compiz-plugins-default libcgmanager0 libcgmanager0:i386 libclutter-gtk-1.0-0 libcompizconfig0 libdecoration0
9 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1463 kB of archives. After unpacking 0 B will be used.

$ update-manager
=> "The software on this computer is up to date" in a pop-up

2015-01-15 :
update-manager suggests to upgrade libclutter-gtk-1.0-0
On 2015-01-14, this package was not suggested by update-manager but was suggested by aptitude .

2015-01-16 :
update-manager suggests to upgrade libcgmanager0
On 2015-01-14, this package was not suggested by update-manager but was suggested by aptitude .

2015-01-23 :
 aptitude safe-upgrade -s
The following packages will be upgraded:
  compiz compiz-core compiz-gnome compiz-plugins-default libcompizconfig0 libdecoration0 python-cupshelpers
  system-config-printer-common system-config-printer-gnome system-config-printer-udev
The following packages are RECOMMENDED but will NOT be installed:
  avahi-utils
10 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1 610 kB of archives. After unpacking 2 048 B will be used.
Do you want to continue? [Y/n/?]
Would download/install/remove packages.

$ update-manager
=> "The software on this computer is up to date" in a pop-up

2015-01-26 :
$ aptitude safe-upgrade -s
The following packages will be upgraded:
  compiz compiz-core compiz-gnome compiz-plugins-default libcompizconfig0 libdecoration0
6 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1 387 kB of archives. After unpacking 0 B will be used.
Do you want to continue? [Y/n/?]
Would download/install/remove packages.

$ update-manager
=> "The software on this computer is up to date" in a pop-up

Thanks.

affects: unity (Ubuntu) → update-manager (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers