Ubuntu

Update manager changelogs not very useful

Reported by Peter van Hardenberg on 2005-03-09
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

As it stands, the update manager only shows changelog entries since the last
installed version.

Unfortunately, the changelog often looks like this (from evolution-exchange on 8
Mar. 2005):

Version 2.2.0-0ubuntu1:

  * New upstream release.

This doesn't really tell me anything at all. Much more useful would be if the
actual changelog from the upstream version was also included, perhaps appearing
between ubuntu tagged releases.

Thanks,
-pvh

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This is really more a social problem than a technical one. I think with the more
widespread use of update-manager the maintainers will include more usefull
changelog items and/or links to the upstream changelog. You may want to raise
this issue on the debian-devel mailinglist.

Thanks,
 Michael

Marco Rodrigues (gothicx) wrote :

It's better to have it linked, e.g: http://changelogs.ubuntu.com/changelogs/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu8/changelog

So we can see all the history...

Michael Vogt (mvo) on 2007-10-16
Changed in update-manager:
assignee: mvo → nobody
Savvas Radevic (medigeek) wrote :

I can confirm the same problem on Ubuntu Hardy Heron alpha (updated), the changelog of each package at changelogs.ubuntu.com should be updated some several minutes *before* a package release.
@ M.Vogt: Does your comment still stand for hardy heron 8.04 alpha?

I thought the problem is probably a delayed update of the changelog at changelogs.ubuntu.com - Because I sometimes get a kernel-related packages without any changelog, are the kernel package builders that unsocial?

Changed in update-manager:
status: Confirmed → Triaged

This isn't a bug as such, it's a suggestion. Because of this, I feel the best place to raise this is brainstorm.ubuntu.com so I am closing the bug.

I agree with the request, so if you start a brainstorm for it I'd be happy to vote on it there.

Changed in update-manager:
status: Triaged → Invalid
Jean-Baptiste Lallement (jibel) wrote :

This is not a bug but this is a valid request anyway. That's why it was triaged/wishlist. For your reference informations about statuses and importance can be found at https://wiki.ubuntu.com/Bugs/Importance and https://wiki.ubuntu.com/Bugs/Status .

Thank you for your help in triaging bugs.

Changed in update-manager:
status: Invalid → Triaged
to be removed (liw) wrote :

A .deb may contain, in /usr/share/doc/$PACKAGE, both a packaging changelog (changelog.Debian.gz) and upstream changelog (changelog.gz), or just the packaging one (changelog.gz). To implement this wishlist, the following should happen:

* changelogs.ubuntu.com should include both files, if available

* the upstream changelog should be .../changelog.upstream, for backwards compatibility and consistency

* update-manager needs a third tab for the upstream changelog

This should be pretty straightforward, once more important stuff gets fixed. The changes on server-side are going to require someone from Canonical, I think, but the rest could be done by one. Anyone?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.