Could not calculate upgrade from 12.04LTS to 14.04.1LTS

Bug #1357566 reported by Alex Ahn on 2014-08-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using 12.04 LTS, and the update manager tried to upgrade to 14.04.1 LTS.

In the section for new software channels, it was at the part where it was calculating changes, but it stopped saying that an unresolvable problem occured. Below is the message. After I pressed okay on the window, the upgrader restored the original settings before quitting.

"Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal."

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.14.17
ProcVersionSignature: Ubuntu 3.13.0-34.60~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic i686
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: i386
Date: Fri Aug 15 17:16:26 2014
EcryptfsInUse: Yes
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1408115250
 com.ubuntu.update-manager window-height 567
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 (20130213)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
Symptom: ubuntu-release-upgrader-core
UpgradeStatus: Upgraded to precise on 2014-08-15 (0 days ago)
VarLogDistupgradeTermlog:

Alex Ahn (nisnamanarhat) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Raymond Meyer (rayfrommo) wrote :

Same issue attempting to upgrade from 12.0.4.2 to 14.04.1.

Any possiblitlity that this error could actually log what the issue is somewhere so there could be more information to assist in a resolution??

John Zero (johnzero-7) wrote :

Same issue here. Ubuntu 12.04 LTS to 14.04.1 LTS upgrade, with ubuntu server.

No success.

do-release-upgrade says at the end
--------------------------
Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu
--------------------------

# grep Broken /var/log/dist-upgrade/apt.log
Broken libkrb5-3:i386 Conflicts on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs )
Broken xz-utils:i386 Conflicts on xz-lzma [ i386 ] < 5.1.1alpha+20110809-3 > ( utils )
Broken libdns46:i386 Depends on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs ) (>= 1.6.dfsg.2)
Broken apache2-bin:i386 Conflicts on apache2.2-common [ i386 ] < 2.2.22-1ubuntu1.7 > ( httpd )
Broken mailutils-common:i386 Breaks on libmailutils2 [ i386 ] < 1:2.2+dfsg1-5 > ( libs ) (< 1:2.3)
Broken smbfs:i386 Depends on cifs-utils [ i386 ] < 2:5.1-1ubuntu2 -> 2:6.0-1ubuntu2 > ( otherosfs ) (= 2:5.1-1ubuntu2)
Broken libkrb5-3:i386 Conflicts on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs )
Broken libdns46:i386 Depends on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs ) (>= 1.6.dfsg.2)
Broken libkrb5-3:i386 Conflicts on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs )
Broken libdns46:i386 Depends on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs ) (>= 1.6.dfsg.2)
Broken libisccfg40:i386 Depends on libdns46 [ i386 ] < 1:9.5.1.dfsg.P2-1ubuntu0.4 > ( libs )
Broken libbind9-40:i386 Depends on libdns46 [ i386 ] < 1:9.5.1.dfsg.P2-1ubuntu0.4 > ( libs )
Broken postgresql-8.3:i386 Depends on libkrb53 [ i386 ] < 1.10+dfsg~beta1-2ubuntu0.5 > ( oldlibs ) (>= 1.6.dfsg.2)
Broken postgresql-contrib-8.3:i386 Depends on postgresql-8.3 [ i386 ] < 8.3.12-0ubuntu9.04 > ( misc )

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

John Zero (johnzero-7) wrote :

I have successfully resolved this.

I had to apt-get remove libkrb5-3 (which removed Postgres 8.3, but no problem for me), after that, the upgrade went smooth.

Paul Marxhausen (pmarxhausen) wrote :

OK, but openssh-server depends upon libkrb5-3.

Paul Marxhausen (pmarxhausen) wrote :

and actually, I just now realized that I successfully ran do-release-upgrade 12.04 to 14.04 on a couple of other machines that also run openssh-server and have libkrb5-3 , with no problems, so my machine with this same bug may have a different issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers