"/boot full" error, even after emptying. Encrypted hdd.

Bug #1349172 reported by CTolley on 2014-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Cannot install large "Ubuntu base" updates. Smaller updates work fine, but 80+M do not. I have cleaned all but the current kernel out of /boot, but the error persists. I have tried many steps, and am only submitting the bug report after no fix was discovered on this thread:

http://ubuntuforums.org/showthread.php?t=2235403

I checked the box for security vulnerability only because of the "Ubuntu base" updates being the problem. I have not had any security issues at this time.

ctolley@####-K61IC:~$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

ctolley@####-K61IC:~$ apt-cache policy update-manager
update-manager:
  Installed: 1:0.196.12
  Candidate: 1:0.196.12
  Version table:
 *** 1:0.196.12 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.196.11 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: update-manager 1:0.196.12
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jul 27 15:36:36 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'window-width' b'484'
 b'com.ubuntu.update-manager' b'launch-time' b'1406489744'
InstallationDate: Installed on 2014-05-14 (74 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

CTolley (ctolley64) wrote :
Seth Arnold (seth-arnold) wrote :

Sometimes GUI environments don't delete files when you delete them, instead it moves them someplace else, making it far harder to find the files to remove.

I suggest looking through ls -la /boot/ output to look for potentially hidden files. If /boot isn't on its own filesystem you may need to look elsewhere for a way to free up some space. It might be best to head to IRC for help so you can get some interactive advice.

Thanks

information type: Private Security → Public
CTolley (ctolley64) wrote :

My output is below:

ctolley@####-K61IC:~$ ls -la /boot/
total 39412
drwxr-xr-x 5 root root 3072 Jul 23 11:43 .
drwxr-xr-x 25 root root 4096 Jul 18 10:52 ..
-rw-r--r-- 1 root root 1162257 Jul 4 18:18 abi-3.13.0-30-generic
-rw-r--r-- 1 root root 165576 Jul 4 18:18 config-3.13.0-30-generic
drwxr-xr-x 5 root root 1024 Jul 24 08:41 grub
-rw-r--r-- 1 root root 29134859 Jul 23 11:43 initrd.img-3.13.0-30-generic
drwx------ 2 root root 12288 May 14 08:39 lost+found
-rw-r--r-- 1 root root 176500 Mar 12 08:31 memtest86+.bin
-rw-r--r-- 1 root root 178176 Mar 12 08:31 memtest86+.elf
-rw-r--r-- 1 root root 178680 Mar 12 08:31 memtest86+_multiboot.bin
-rw------- 1 root root 3378641 Jul 4 18:18 System.map-3.13.0-30-generic
drwx------ 4 root root 1024 Jul 18 10:17 .Trash-0
-rw------- 1 root root 5792608 Jul 4 18:18 vmlinuz-3.13.0-30-generic

Before this issue, I had 4 kernels and accompanying files. Now, it's only the one kernel and other required stuffs.

CTolley (ctolley64) wrote :

Also, boot is on it's own file system. I have roughly 250G free on the usable hdd. In future installs, I won't separate /boot, but it seemed logical at the time, and I haven't had an issue since I started using Ubuntu at 8.10. This is my first encrypted install, and other encrypted users are experiencing the exact same error.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers