"hwe-support-status --show-all-unsupported" fails

Bug #1341324 reported by frankster on 2014-07-13
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Brian Murray
Precise
Undecided
Unassigned

Bug Description

TEST CASE:
1. install 12.04
2. apt-get install linux-image-generic-lts-saucy
3. install update-manager-core from precise-updates
4. run hwe-support-status --show-all-unsupported
5. verify it crashes
6. install update-manager-core from precise-proposed
7. repeat step 4
8. verify that it works this time.

Expected behaviour:
"hwe-support-status --show-all-unsupported" lists any unsupported HWE packages

Actual behaviour:
hwe-support-status crashes with the following stack:

Traceback (most recent call last):
  File "/usr/bin/hwe-support-status", line 235, in <module>
    print(twrap(" ".join(unsupported_hwe_packages)))
TypeError: sequence item 0: expected string, instance found

Ubuntu release is mythbuntu (Ubuntu 12.04.4 LTS)
update-manager-core version is "1:0.156.14.15"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager-core 1:0.156.14.15
ProcVersionSignature: Ubuntu 3.11.0-20.35~precise1-generic 3.11.10.6
Uname: Linux 3.11.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.6
Aptdaemon:

Architecture: amd64
Date: Sun Jul 13 17:05:11 2014
GsettingsChanges:

InstallationMedia: Mythbuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to precise on 2012-05-30 (773 days ago)

frankster (wtfrank) wrote :
frankster (wtfrank) wrote :

This patch fixes the python error.

The attachment "hwe-bug.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Brian Murray (brian-murray) wrote :

Could you take a look at this Michael?

Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2014-07-16
Changed in update-manager (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Michael Vogt (mvo) on 2014-07-16
description: updated
Paul Pace (openletter) wrote :

Just want to add that I installed using the vanilla Ubuntu Server 12.04 download image and this bug affects me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu Precise):
status: New → Confirmed

Hello frankster, or anyone else affected,

Accepted update-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/update-manager/1:0.156.14.16 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Erick Brunzell (lbsolost) wrote :

I'm working on verification, looks good so far, but in an overabundance of caution I'm testing with all available HWE stacks .................. and just noticed that I should actually combine with SRU testing for bug #1342424 ................. so this is really just a note to myself.

Erick Brunzell (lbsolost) wrote :

Looks good so changed to verification-done. I tested with all available HWE stacks.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156.14.16

---------------
update-manager (1:0.156.14.16) precise-proposed; urgency=low

  * HweSupportStatus/consts.py:
    - use ISO date format instead of the locales date format because
      pam_motd does not set the LANG environment (LP: #1342424)
  * hwe-support-status:
    - fix crash with hwe-support-status --show-all-unsupported,
      thanks to "frankster" (LP: #1341324)
 -- Michael Vogt <email address hidden> Wed, 16 Jul 2014 10:38:59 +0200

Changed in update-manager (Ubuntu Precise):
status: Fix Committed → Fix Released
Paul Pace (openletter) wrote :

Is it possible someone could take a look at bug #1341320?

Changed in update-manager (Ubuntu):
assignee: Michael Vogt (mvo) → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

I've forward ported the HWE support status code to Yakkety, so I'm setting this to Fix Released.

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers