Broken packages result in meaningless error message

Bug #133325 reported by Warbo on 2007-08-18
This bug report is a duplicate of:  Bug #146817: broken packages message is confusing. Edit Remove
106
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

If broken packages are on the system then update manager brings up an error message asking the user to "use the broken fileter", which is a feature of Synaptic which is not accessible from the update manager tool. The text should be changed to read something like "Broken packages were found on this system. The update tool cannot correct this, please use a different package tool to fix this issue", perhaps with a button to open Synaptic if it is installed.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Update-manager should already be able to detect broken packages and display a meaningful error message. Could you please tell me how to reproduce this problem and maybe attach a screenshot ?

Changed in update-manager:
status: New → Incomplete
Paul Dufresne (paulduf) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
assignee: nobody → dufresnep
status: Incomplete → Invalid
Greg Michalec (greg-primate) wrote :

Hi -
I'm using latest Hardy, and this error message is still present. Update-manager does detect the broken packages correctly, and does display an error message. The bug is that the error message: "You have 2 broken packages on your system! Use the "Broken" filter to locate them." does not apply to update-manager. I believe it is referring to synaptic. To a new user, this is not very helpful, and probably confusing. Steps to reproduce:
1) Somehow get a broken package setup (not too hard for those of us living on the edge)
2) Open update-manager
3) Press check, and wait for update to finish
4) See error message
5) Close error message
6) Think "where the heck is the 'broken' filter?"

I agree with the original reporter's suggestion for a proper error message.
I'm attaching a screenshot.

Changed in update-manager:
status: Invalid → New
Matthew Woerly (nattgew) wrote :

I agree that this should be changed to be more clear.

Changed in update-manager:
status: New → Confirmed

I have had this message in the same situation. Do I need to do anything when i receive this message?

Warbo (warbo) wrote :

Daniel S: You can fix broken packages by going into the Synaptic Package Manager (in System>Administration). The "broken filter" referred to is in there. Packages may be broken for a variety of reasons, see https://help.ubuntu.com/community/SynapticHowto#How%20to%20fix%20broken%20packages .

Stuart Read (sread) wrote :

This bug is still present in Intrepid. I also agree with the idea of adding some reference to synaptic as a method to fix the broken state to the error message.

sampablokuper (sampablokuper) wrote :

I've just observed it on a laptop running 8.04 LTS. I agree with Warbo, Greg Michalec, Nattgew and Stuart about this: the error message needs to be improved. Currently, it's not at all clear how a user ought to find the "broken filter", so unless the user googles the problem, they'll be left with a (partially) broken system and a feeling of dissatisfaction.

unsubscibe

On 12/28/08, sampablokuper <email address hidden> wrote:
> I've just observed it on a laptop running 8.04 LTS. I agree with Warbo,
> Greg Michalec, Nattgew and Stuart about this: the error message needs to
> be improved. Currently, it's not at all clear how a user ought to find
> the "broken filter", so unless the user googles the problem, they'll be
> left with a (partially) broken system and a feeling of dissatisfaction.
>
> --
> Broken packages result in meaningless error message
> https://bugs.launchpad.net/bugs/133325
> You received this bug notification because you are subscribed to update-
> manager in ubuntu.
>

--
Thanks & Regards,

Virender Sharma (Investment Advisor), ARN-56116
S/o Sh. Vijay Kumar Sharma,
C/o Sharma Shuttering Store,
Chowk Jallowkhana,
Kapurthala-144601 (Punjab), India.

Mobile: +91-9357270208
Office: 01822-2305089, 221621
Email: <email address hidden>
(Please Contact for all your Life Insurance & Mutual Fund Investmensts needs.)

Visit Our City Website: www.kapurthalaonline.com

"The future belongs to those who believe in beauty of their dreams"

visibility: public → private
visibility: private → public
BruceW (bmw-greencampaigns) wrote :

Still get same error despite there being NO BROKEN PACKAGES.

Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug #146817, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers