update-manager crashed with BadStatusLine in _read_status()

Bug #132474 reported by mjukr on 2007-08-14
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

gusty, updating on 14 August, crashed with this message

ProblemType: Crash
Architecture: i386
Date: Tue Aug 14 11:22:23 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: fglrx ath_hal
Package: update-manager 1:0.68
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager
ProcCwd: /home/kirchhme
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with BadStatusLine in _read_status()
Uname: Linux Fortnight 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

Michael Vogt (mvo) wrote :

The exception looks more like a proxy problem to me, are you behind a proxy?

...
  File "httplib.py", line 924, in getresponse
    response.begin()
  File "httplib.py", line 385, in begin
    version, status, reason = self._read_status()
  File "httplib.py", line 349, in _read_status
    raise BadStatusLine(line)
BadStatusLine

Changed in update-manager:
status: New → Incomplete

No, but I am behind a NAT Router, if that makes any difference...

Changed in update-manager:
status: Incomplete → New
Wim (wimvandender) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 204075 (Which is fixed), so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in update-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers