update-manager / aptdaemon TransactionFailed crashes are not problems with update-manager

Bug #1317164 reported by Brian Murray on 2014-05-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

On errors.ubuntu.com there are multiple crashes reported about update-manager that end in a Traceback like the following:

aptdaemon.errors.TransactionFailed: Transaction failed: The package system is broken
 The following packages have unmet dependencies:

rhythmbox-plugin-magnatune: Depends: rhythmbox (= 3.0.2-0ubuntu2) but 3.0.2-0ubuntu1 is installed

Naturally, the package name varies. I don't believe these are actually crashes about update-manager or aptdaemon. Rather there is something wrong with the users package system. Subsequently, it'd be better if these were not reported to the error tracker and clogging up the bug lists.

tags: added: trusty utopic
Changed in update-manager (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-14.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed

The bug report being referred to is bug #1097946 software-center crashed with TransactionFailed in _run_transaction(): <unprintable TransactionFailed object>

Changed in update-manager (Ubuntu):
milestone: ubuntu-14.10 → ubuntu-15.04
tags: added: rls-v-incoming
tags: added: rls-v-notfixing
removed: rls-v-incoming
Martin Pitt (pitti) on 2015-04-20
Changed in update-manager (Ubuntu):
milestone: ubuntu-15.04 → vivid-updates
Brian Murray (brian-murray) wrote :

Thinking about this some more I think there is actually something wrong here, possibly people trying to install updates who have an outdated package list, and that we should not mask these issue by not reporting them.

Changed in update-manager (Ubuntu):
milestone: vivid-updates → none
peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers