Window should close when "Restart now" is clicked

Bug #1297361 reported by Marc Deslauriers
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

When update manager pops the dialog that requests the computer be rebooted, clicking the "Restart now" button results in the shell reboot window popping _over_ the update-manager dialog.

Once update-manager has dispatched the reboot request, it should close its window.

See attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: update-manager 1:0.196.7
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Aptdaemon:

Architecture: amd64
CurrentDesktop: Unity
Date: Tue Mar 25 11:19:59 2014
GsettingsChanges:
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'556'
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'window-width' b'628'
 b'com.ubuntu.update-manager' b'launch-time' b'1395672996'
InstallationDate: Installed on 2013-11-26 (118 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: Upgraded to trusty on 2014-01-17 (66 days ago)

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :
Changed in update-manager (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.9

---------------
update-manager (1:0.196.9) trusty; urgency=medium

  [ Sebastien Bacher ]
  * UpdateManager/UpdatesAvailable.py:
    - use the correct icon theme (lp: #1283554)

  [ Marc Deslauriers ]
  * UpdateManager/Dialogs.py: close window after requesting reboot.
    (LP: #1297361)

  [ Michael Vogt ]
  * tests/aptroot-update-list-test:
    - fix test failure caused by not-installable depends (lp: #1295392)
 -- Michael Vogt <email address hidden> Wed, 26 Mar 2014 12:52:13 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers