test suite failures

Bug #1295392 reported by Barry Warsaw
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

update-manager's test suite fails. bdmurray pointed me at this command:

xvfb-run nosetests3 -s --tests tests/test_update_list.py

which produced 5 failures and one error. The error I think was easy enough to fix, since it was dependent on the random number returned when calculating phased updates, and that is dependent on the machine id. I mocked that out to get consistent results.

The test failures all seem to point to a change in behavior for pkg.is_upgradable, since the updates_list is a different size than expected (expected: 3, actual: 1). Brian's seeing the same thing.

I'll link a branch that fixes the test bug, but atm I'm kind of stumped at why .is_upgradable is not what's expected.

Related branches

tags: added: trusty
Revision history for this message
Brian Murray (brian-murray) wrote :

I've tested python-apt as far back as version 0.9.0 without any effect on the tests. I wonder if it isn't actually caused by a change in apt.

Revision history for this message
Brian Murray (brian-murray) wrote :

Well installing apt 0.9.14.1ubuntu2 changes the update_list back to what the test expects.

Revision history for this message
Brian Murray (brian-murray) wrote :

And they fail with apt version 0.9.15.1ubuntu1.

Revision history for this message
Barry Warsaw (barry) wrote : Re: [Bug 1295392] Re: test suite failures

On Mar 20, 2014, at 10:53 PM, Brian Murray wrote:

>I've tested python-apt as far back as version 0.9.0 without any effect
>on the tests. I wonder if it isn't actually caused by a change in apt.

Looking at the changelog for apt in Ubuntu, there have been a fair number of
uploads in the last month. Maybe try some of those older versions?

Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Michael Vogt (mvo) wrote :

This is a regression in apt caused by commit 446551c8ffd2c9cb9dcd707c94590e73009f7dd9

I will look what exactly is causing this.

Thanks,
 Michael

Michael Vogt (mvo)
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.9

---------------
update-manager (1:0.196.9) trusty; urgency=medium

  [ Sebastien Bacher ]
  * UpdateManager/UpdatesAvailable.py:
    - use the correct icon theme (lp: #1283554)

  [ Marc Deslauriers ]
  * UpdateManager/Dialogs.py: close window after requesting reboot.
    (LP: #1297361)

  [ Michael Vogt ]
  * tests/aptroot-update-list-test:
    - fix test failure caused by not-installable depends (lp: #1295392)
 -- Michael Vogt <email address hidden> Wed, 26 Mar 2014 12:52:13 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers