Looks like wrong icon theme is used

Bug #1283554 reported by Dimitri John Ledkov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Sebastien Bacher

Bug Description

Software updater, when either self-pop ups or when manually launched, appears to be using a different theme from that of the default / user set.

In particular, I believe the package icon and the distributor logo icons are used from a fallback gnome icon theme instead of the default one. I'm not certain however, can it somehow be inspected which icons are loaded and used?

Maybe since it elevates privileges, different defaults are used?

(i'm currently in progress updating all the themes where vintage circle of friends is used, but i believe wrong icon theme is the root cause for software updater using older looking icons.)

Related branches

Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

system settings is up for upgrade, and it shows it with a Gnome blue screwdriver and wrench icon, instead of red wrench and large cog icon.

Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

The correct logo is used for ubuntu there. Do you get that issue every time?

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1283554] Re: Looks like wrong icon theme is used

On 19 March 2014 17:54, Sebastien Bacher <email address hidden> wrote:
> The correct logo is used for ubuntu there. Do you get that issue every
> time?

Not really, it's just I uploaded updated logo into all of the themes =)

A better example:
* In Software updater the "package icon" is a box partially opened to the right
* Default Ubuntu icon for "package icon" (e.g. any archive / .deb /
.ar etc) is a sealed cardboard box with a selotape and a pale debian
swirl on the front (or words .tar.gz etc.)

When there is update available for apps with stock icons wrong logos are used:
* System settings i blue screw-driver and a wrench, instead of a red
wrench and large cog
* Printers is a bottom paper feed icon, instead of top paper feed icon
* startup applications icon is blue, not purple

Etc.

Let me attach a screenshot.

--
Regards,

Dimitri.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Changed in update-manager (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
status: Confirmed → In Progress
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.9

---------------
update-manager (1:0.196.9) trusty; urgency=medium

  [ Sebastien Bacher ]
  * UpdateManager/UpdatesAvailable.py:
    - use the correct icon theme (lp: #1283554)

  [ Marc Deslauriers ]
  * UpdateManager/Dialogs.py: close window after requesting reboot.
    (LP: #1297361)

  [ Michael Vogt ]
  * tests/aptroot-update-list-test:
    - fix test failure caused by not-installable depends (lp: #1295392)
 -- Michael Vogt <email address hidden> Wed, 26 Mar 2014 12:52:13 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers