update reported error in gtk-update-icon-cache

Bug #1282276 reported by Susan Cragin on 2014-02-19
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

The following information is quoted from the terminal output:

(gtk-update-icon-cache-3.0:23320): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: update-manager 1:0.196.7
ProcVersionSignature: Ubuntu 3.13.0-10.30-generic 3.13.3
Uname: Linux 3.13.0-10-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Aptdaemon:

Architecture: amd64
CurrentDesktop: Unity
Date: Wed Feb 19 16:35:27 2014
GsettingsChanges: b'com.ubuntu.update-manager' b'launch-time' b'1392815113'
InstallationDate: Installed on 2014-02-05 (14 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140205)
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Susan Cragin (susancragin) wrote :
Susan Cragin (susancragin) wrote :

When I tried to do what it suggested, I got the following:

susan@susan:~$ sudo gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
bash: /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache: Permission denied

Brian Murray (brian-murray) wrote :

with the command you've used only 'gdk-pixbuf-query-loaders' was run as sudo and the redirection of the output to /usr/lib/x86_64-linux-gnu/... was done as yourself.

Try sudo -i to start a root prompt then run:

gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache

Then logout as root.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Peter Lemieux (seijisensei) wrote :

Running as root:

# gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
The program 'gdk-pixbuf-query-loaders' is currently not installed. You can install it by typing:
apt-get install libgdk-pixbuf2.0-dev

After installing that package I can run the gdk-pixbuf-query-loaders command.

It's estimated to have a moderate impact on a large portion of Ubuntu users.

Changed in update-manager (Ubuntu):
importance: Undecided → High
Peter Lemieux (seijisensei) wrote :

This bug persists while upgrading to Xubuntu 14.04 using do-release-upgrade today.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers