update-manager crashed with AttributeError in start(): 'NoneType' object has no attribute 'set_functions'

Bug #1219414 reported by Vincent Aleister Portier on 2013-09-01
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Red exclamation point in task bar. Clicked "show updates".

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: update-manager 1:0.193
ProcVersionSignature: Ubuntu 3.11.0-3.8-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Aptdaemon:

Architecture: amd64
CrashCounter: 1
Date: Sun Sep 1 05:51:55 2013
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1378032708'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'587'
 b'com.ubuntu.update-manager' b'window-width' b'484'
InstallationDate: Installed on 2013-07-07 (55 days ago)
InstallationMedia:

InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/update-manager --no-update
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager', '--no-update']
SourcePackage: update-manager
Title: update-manager crashed with AttributeError in start(): 'NoneType' object has no attribute 'set_functions'
UpgradeStatus: Upgraded to saucy on 2013-07-08 (54 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

tags: removed: need-duplicate-check
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
Iain Lane (laney) on 2013-09-26
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

This seems to happen if the system is in a "restart-needed" state before "update-manager --no-update" is called, as would happen if someone (like me) mixes and matches their apt-get and update-manager usage.

Adolfo Jayme (fitojb) on 2013-10-03
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.194

---------------
update-manager (1:0.194) saucy; urgency=low

  * Fix a bug introduced in the dialog refactor from version 1:0.189 that
    causes update-manager to crash instead of showing a dialog when there are
    no updates to apply but the system needs rebooted. LP: #1219414.
 -- Steve Langasek <email address hidden> Thu, 03 Oct 2013 13:31:18 -0700

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers