installing/updating tools need to detect EOL versions

Bug #1199060 reported by dino99 on 2013-07-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Digging around bugs reported on bugs.launchpad, i've seen a bunch of reports rised by users (mostly new comers i suppose) not knowing about versions having reached EndOfLife.
 Most of these reports was against "solftware-center" : like, "got server error 500" or "i does not understand why software-center cant download even if my network works with the browser". So launchpad get flooded by invalid reports.

Users have to be aware of such a case : the different tools (installer/updater) should detect the different EOL version, and be able to display a popup message saying something like "that version is no more available, choose a newer ubuntu release"; on the other hand Apport also need to refuse such reports.

Related packages : apt, synaptic, software-center (for the gnome world; but i suppose the other DEs are also concerned)

<https://wiki.ubuntu.com/SoftwareUpdates#upgrades>: "If no updates are available but a new version of Ubuntu is, the alert should have “Upgrade…” and “OK” buttons (replacing the separate “Ubuntu {version} Upgrade Available” dialog), and text depending on the situation..."

dino99 (9d9) wrote :
tags: added: precise quantal raring
dino99 (9d9) on 2013-07-08
affects: linux (Ubuntu) → software-center
affects: software-center → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Wishlist
affects: linux (Ubuntu) → software-center (Ubuntu)
Changed in software-center (Ubuntu):
importance: Wishlist → Undecided
status: Confirmed → New
Dave Morley (davmor2) wrote :

Software updater would be a better option for this as software-center only knows it is on a distribution.

no longer affects: software-center (Ubuntu)
affects: software-center → update-manager
dino99 (9d9) wrote :

Software-center also needs to be a bit more clever and check the sources validity to download only from alive release sources; as Ubuntu now mostly communicate only about software-center (compared to the old tools : apt-get, synaptic, ...). And indeed the new comers cant be aware that they are trying to upgrade a distro having reached EOL.

affects: update-manager → update-manager (Ubuntu)
description: updated
Changed in update-manager (Ubuntu):
status: New → Triaged
Adolfo Jayme (fitojb) on 2013-07-18
Changed in update-manager (Ubuntu):
importance: Undecided → Wishlist
Peter Kopias (petros-k) wrote :

I would suggest that update manager should notify the user of the distro's end of life at least 2 weeks before that time arrives.

Same goes for apt in cli.

So theoretically no one would use an unsupported distro because lack of information.

dino99 (9d9) on 2015-03-24
tags: added: trusty utopic vivid
removed: quantal raring saucy
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers