update-manager failing to install anything in saucy

Bug #1189677 reported by Steve Langasek on 2013-06-11
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
policykit-1 (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

In saucy, update-manager is completely failing to install any packages. It auto-launches and presents me the list of packages to install; but when I click 'Install now', the window closes and update-manager exits. Running u-m from the console shows there are no error messages and the process exits 0.

If I run update-manager without the '--no-update' flag, I'm given a dialog saying:

 You are not allowed to perform this action

 You don't have the required privileges to perform this action.

 Settings Try Again OK

This suggests that there is probably a policykit issue here. However, that issue isn't going to resolve itself, so update-manager needs to notify the user of the problem instead of silently exiting.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: update-manager 1:0.188
ProcVersionSignature: Ubuntu 3.9.0-3.8-generic 3.9.4
Uname: Linux 3.9.0-3-generic x86_64
ApportVersion: 2.10.2-0ubuntu1
Aptdaemon:

Architecture: amd64
Date: Mon Jun 10 16:44:59 2013
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1370907861'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'747'
 b'com.ubuntu.update-manager' b'window-width' b'850'
InstallationDate: Installed on 2010-09-24 (990 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: Upgraded to saucy on 2013-05-06 (35 days ago)

Steve Langasek (vorlon) wrote :
Changed in update-manager (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
dino99 (9d9) wrote :

Saucy has died a while ago

Changed in policykit-1 (Ubuntu):
status: New → Invalid
Steve Langasek (vorlon) wrote :

This bug has not been fixed. Do not mark bugs as "fix released" when the code has not been changed to address the issue described.

Changed in update-manager (Ubuntu):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers