linux-libc-dev update dependency problem

Bug #116785 reported by Tim Parker on 2007-05-25
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

On 6.10 i386. linux-libc-dev is permanently being reported an available update from 2.6.17.1-11.37 to 2.6.20-15.27, although the system is using kernels no later than 2.6.17-11 (all kernels from standard update process - no 'extra' kernels installed by hand). It seems that the libc kernel header package is not checking the installed kernel versions. This may in part be related to bug #37937, in which the fact that the linux-libc-dev is treated as a separate package causes problems. The rejection of that bug seemed to miss the point, viz :-

On mar, 2006-04-04 at 01:24 +0000, Matt Zimmerman wrote:

> The headers are not installed by default; if you want them, install the corresponding linux-headers-<foo> package for the linux-<foo> package you are using, and it will track the same versions.
>
> ** Changed in: Ubuntu
> Status: Unconfirmed => Rejected

The headers are NOT tracking the versions of the kernel (if i'm reading Matt replies correctly). It makes no sense, and is a potential build issue, to update the headers regardless of the kernel version... also irritating that you cannot 'turn off' the update warning from the update-manager without uninstalling the package.. but this is linked with the dependency issue between the kernel and the header package which seems to have been ignored. Shurly shome mysteak.

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
status: Incomplete → Invalid
Tim Parker (tim-fukawitribe) wrote :

> We are closing this bug report

Ok - no problem

> because it lacks the information we need to investigate the problem,

No it doesn't - the information is all there and in the cross-referenced bug report AFAICS and no further request for information regarding this was made here.

> as described in the previous comments.

No it wasn't - and what this "missing" information may or may not be has not been explained (please don't say you couldn't try and reproduce without knowing whether later versions also, as that is not relevant in this case). However, seeing as this seemed to be a distribution specific bug for which the distribution is no longer actively supported - and does not seem to manifest in a similar form in later distributions - then i'm ok with it closing... just as long as the reason for closing is given correctly.

Sorry about the tone - I honestly do very much appreciate all the work put in but as a software devvie myself, people trying to close bugs with completely bogus reasons really gets on my nerves.

Best regards
Tim

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers