When upgrade manager crashes, upgrade can't be resumed

Bug #115131 reported by Scott Severance on 2007-05-16
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

My upgrade from Edgy to Feisty failed when the update manager crashed (see bug #115122). When I tried to restart update-manager, it didn't re-offer the upgrade, nor did it start the upgrade GUI. I don't know how important the upgrade program (that powers the GUI) is, but it should be possible to resume where the crash happened.

Dennis Francis (dennisfrancis) wrote :

Thank you for the report, Scott !

Yes there should definitely be a provision for resumption of upgrades from break point.
Wishlist.

Changed in update-manager:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in update-manager:
assignee: desktop-bugs → nobody
status: Confirmed → Unconfirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in update-manager:
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in update-manager:
status: Incomplete → Invalid

Somehow I missed your last request. I'm not sure that you read my bug report very carefully. This bug isn't about the crash so much as it's about the aftermath. There is (or was) no way to resume an interrupted upgrade. In other words, when running update-manager, it didn't offer an upgrade any longer. Now, I don't know what the difference is, but the lack of such an option is disconcerting. The upgrade button should be present until the upgrade has been completed successfully.

As far as the backtrace goes: This bug was reported back in May. It deals with an upgrade from Edgy to Feisty, so obtaining a backtrace now would be impossible, particularly since the aftermath of the crash left my system in an unusable state (see bug 115122, mentioned in my initial report) so I ended up doing a clean install of Feisty, which has since been upgraded to Gutsy. Any automatic backtrace or log message no longer exists. Besides, a backtrace won't help this bug, anyway.

Changed in update-manager:
status: Invalid → New

Closing this bug, since neither edgy nor feisty are supported anymore. Please reopen the bug if you experience this problem again. Thanks.

Changed in update-manager:
status: New → Invalid

Reopening, because this bug isn't really related to Edgy or Feisty. It's about the fact that in the event of an update manager crash, there needs to be away to resume from the breakpoint. Waiting for another crash--which might or might not happen--to determine whether this capability still needs to be added doesn't make sense.

(If this bug has been fixed without being mentioned here, then the bug should be marked "Fixed", not "Invalid".)

Changed in update-manager:
status: Invalid → New
to be removed (liw) wrote :

Scott, sorry to see you've had to reopen this twice already. Let me surprise you by not closing it. :)

It strikes me that this bug should be easy to reproduce, if one has a system one is willing to risk: start the dist-upgrade, then turn off the computer in the middle of it. Anyone willing to do that?

to be removed (liw) wrote :

I used a virtual machine to test this.

The machine initially had a current intrepid on it. I started the upgrade to jaunty (update-manager -d), and killed the virtual machine while it was installing packages. After rebooting the VM and logging in, the update-notifier informed me the system was broken and needed fixing and gave me instructions on how to start synaptic. So far so good.

Then I went back to the pristine, up-to-date intrepid VM (the joys of virtual machines), and re-started the upgrade to jaunty. This time I killed the upgrade in the middle of downloading the packages. After rebooting the VM and re-starting the interrupted upgrade, it continued downloading from where it had gotten when I killed the VM.

Thus, I think the bug is fixed.

Changed in update-manager:
status: New → Fix Released
Michael Vogt (mvo) wrote :

Lars is right, we have code now that is able to continue a broken upgrade within the limits of what dpkg can do. For a 100% perfect solution we need something like snapshots and/or aufs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers