Orca is skipping key details of the updates list

Bug #1105371 reported by Dylan McCall on 2013-01-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

With the new updates tree view, Orca is correctly reading the name of each update (and whether it can be expanded), but it never reads the toggle cell in the Install column. This means a vision-impaired user has no way of knowing which updates are selected and which are not. This is a regression from Ubuntu 12.10. We need to convince the screen reader to mention whether an update is toggled.

In addition, the screen reader currently says "Image" for every cell in restart_column, even when (99% of the time) there is no image visible. This is noisy and unhelpful. Instead, Orca should say nothing for this cell, unless the restart required icon is being displayed, in which case it should say "Restart required".

These issues were observed Using Orca 3.7.0.94 and GTK+ 3.6.2 in Ubuntu 12.10.

description: updated
Dylan McCall (dylanmccall) wrote :

I'll keep this up to date on what I find, but since I didn't mention in the description: I think this one is going to be harder than it looks.

First, probably worth mentioning that Orca also does not mention the other image inside the Install column. Right now, when I select a row in the updates list, it says "Image, System Settings, Expanded - three Items, 12.5 MB". If it was reading all of the cells, it would say something like "Image, Checkbox - ticked, Image, System Settings, Expanded - three Items, 12.5 MB". If all was right in the world, it would skip both of those images and say (at least) "Checkbox - ticked, System Settings, Expanded - three Items, 12.5 MB". If I change the order of those cells inside the Install column (and use Gtk.CellAreaBox instead of CellAreaPackage), Orca _still_ reads the label cell. The screen reader does mention the toggle cell correctly if it is in its own column, but that is quite unattractive.

I poked at Software Updater with Accerciser and it looks like the stuff inside the Install column all reaches it correctly. The toggle cell inside our GtkCellArea looks exactly like a toggle cell in its own column, except nested a little deeper. I'm hoping that is helpful for someone who knows anything about accessibility. (Eg: Not me). :)

Adolfo Jayme (fitojb) on 2013-02-03
tags: added: a11y raring
Changed in update-manager (Ubuntu):
importance: Undecided → High
peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: New → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Released → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers