Adept Manager and Adept Updater don't use PROXY SETTINGS when checking for distro updates

Bug #109700 reported by Roberto Maurizzi on 2007-04-24
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: adept

I was trying to update from Edgy to Feisty on a computer that's on a very restrictive network (outside access is via http proxy only).
As such I configured both Konqueror and Firefox with a proxy setting script, and added to /etc/profile an export for http_proxy and https_proxy.
apt-get, aptitude and such worked without a problem on this system.

When I tried the upgrade to feisty, following the not so clear instructions on www.kubuntu.org (I'm still looking for the "Version Upgrade" button...), nothing happened... a download windows appeared for a half second but nothing.

After a couple of days (and 2 other computers in different networks upgraded) I started to check if the problem was a direct HTTP access to the version infos and Distribution Upgrade Tool... and it was:

Apr 24 11:52:05 ssi009n038 kernel: [17185923.892000] Shorewall:OUTPUT:REJECT:IN= OUT=eth0 SRC=172.16.149.38 DST=82.211.81.132 LEN=60 TOS=0x00
PREC=0x00 TTL=64 ID=45343 DF PROTO=TCP SPT=47044 DPT=80 WINDOW=5840 RES=0x00 SYN URGP=0

the address 82.211.81.132 resolves to rookery.ubuntu.com, from where I was able to download the upgrade package which I then started manually to upgrade.

Ciao,
  Roberto

Roberto,

Thanks for reporting this bug. It seems like this is the same (or at least closely related) problem that is being tracked as bug 48682.

thanks for helping to improve Kubuntu
Rich

Changed in adept:
status: New → Incomplete
Roberto Maurizzi (r-maurizzi) wrote :

Here the problem is not that proxy settings in the browsers are ignored, but that the env variable http_proxy is ignored too, but *only* for the upgrade check.
The effect is insidious because the rest of the package management (apt, aptitude, synaptic, adept...) works flawlessly after you set the variable.
Only, no upgrades on release :-)

I think Bug #48682 would be mostly fixed by setting system wide proxy settings from the browsers (or maybe better by adding a system wide proxy configuration apps in the Settings, that takes care of proxies in browsers and shell). So, IMHO it's not really an Adept problem: if i manually configure the system, all works.
That is not the case for this problem, since the updater itself is trying to get a file without using a proxy or a proxy aware file downloader. So the problem this time is in Adept.
While the fix for #48682 isn't easy to made, changing Adept to use (for example) KGet via dcop or a kio to download the upgrade file should be far easier :-)

Ciao,
   Roberto

Marco Maini (maini10) wrote :

This problem was happened only during the release upgrade (e.g. Edgy to Feisty) Does it affect Adept when you try to update single packages (e.g. for security updates or similar after the release of Feisty)?
Thanks for your collaboration.

Changed in adept:
assignee: nobody → maini10
Roberto Maurizzi (r-maurizzi) wrote :

No, the usual day to day operations were and are ok with every package manager i tried.
I use regularly aptitude, kpackage and obviously adept to update, upgrade and install packages.
Only the check for a new upgrade program on rookery.ubuntu.com was using a DIRECT connection and failing.

It may be usefult to know that i never set any proxy in apt.conf, the system works using http_proxy variable.

Ciao,
   Roberto.

Marco Maini (maini10) wrote :

Thanks, reassign your report to update-manager, since only dist-upgrade seems affected by this.

Changed in adept:
assignee: maini10 → nobody
status: Incomplete → New
momchil (m-milev) wrote :

this is now a year later, on Kubuntu v.7.10, the upgrade tool does not check/accept/use the network settings proxy

momchil (m-milev) wrote :

note: the version upgrade tool seems to be downloaded from the network, it should be feasible for it to be fixed without downloading a whole new distribution installation CD.

Jean-Baptiste Lallement (jibel) wrote :

This is fixed in Intrepid. Proxy settings can now be set system wide and update-manager uses http_proxy if set or set it from system-wide settings. Don't hesitate to reopen if you're still experiencing this issue when upgrading from intrepid to jaunty.

Thanks.

Changed in update-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers