better mirror support

Bug #108390 reported by James Collins on 2007-04-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: update-manager

Hi,

I have attempted an upgrade from edgy to feisty using the 7.04 alternative cd.

I chose to perform the upgrade using the internet also.

I get the following message:
"Could not calculate the upgrade.
An unresolvable problem occurred while calculating the upgrade.
Please report this bug against update-manager package and include the files in /var/log/dist-upgrade/ in the bug report."

I have attached the log files.

James Collins (james-collins) wrote :
James Collins (james-collins) wrote :
James Collins (james-collins) wrote :

term.log is empty so it wouldn't let me upload it.

The upgrade failes after "modifying the software channels" (ie on the "Fetching and installing the upgrades" step).

James Collins (james-collins) wrote :

The orange update alert icon now says there are 439 updates available.

I am not sure whether I should install them or not?

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It looks like your mirror "http://mirrors.uwa.edu.au/ubuntu/" is not correctly recordnized. Could you please try to switch to a different mirror temporarly (e.g. us.archive.ubuntu.com) and retry?

Thanks,
 Michael

Changed in update-manager:
status: Unconfirmed → Needs Info
James Collins (james-collins) wrote :

Hi Michael,

Thanks for your reply.

This is a mirror that my local university provides. I changed the sources.list to use these instead of au.archive.ubuntu.com because au.archive.ubuntu.com is running very slowly.

I have just changed them back to au.archive.ubuntu.com, reran

gksu "sh /cdrom/cdromupgrade"

select Yes for the include internet sources

I then got a message saying third party sources will be disabled, and clicked OK.

I then got a popup that said:
13 packages are going to be removed
- python-id3lib
- hwdb-client
- apache2-common
- python-musicbrainz
- apt-index-watcher
- libvolumeid0
- libvolumeid
- libapache2-mod-python2.4
- lib-apache2-mod-php4
- python-gst
- ntp-server
- human-gtk-theme
- python-parted
- php5-mysqli
119 new
1433 to be upgraded

567M total

I clicked start, and the packages are fetching now. So far so good.

James Collins (james-collins) wrote :

Hi,

Just letting you know that the upgrade seems to have completed successfully.

Thanks for the help.

James

Michael Vogt (mvo) wrote :

Thanks James, I'm happy that it works for you now.

Changed in update-manager:
status: Needs Info → Confirmed
Changed in update-manager:
importance: Undecided → Wishlist
Rolf Leggewie (r0lf) wrote :

Is there anything that needs to or even can be done in the update-manager package itself?

Changed in update-manager (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

mvo set this bug to confirmed and milestone Ubuntu-later, so I guess the answer to my question is "yes".

Changed in update-manager (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

There is an environmental variable that update-manager recognizes that allows you use a local mirror so I am setting this bug to Fix Released. That variable is:

"RELEASE_UPRADER_ALLOW_THIRD_PARTY" in os.environ

Changed in update-manager (Ubuntu):
milestone: later → none
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments