update-manager crashed with RuntimeError in /usr/lib/python3/dist-packages/gi/overrides/Gtk.py: Gtk couldn't be initialized

Bug #1053292 reported by Josh Holland
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Confirmed
Medium
Unassigned

Bug Description

Not sure what happened, Apport window popped up.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: update-manager 1:0.173
ProcVersionSignature: Ubuntu 3.5.0-15.20-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.2-0ubuntu1
Aptdaemon:

Architecture: amd64
Date: Wed Sep 19 16:36:04 2012
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1347958265'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'621'
 b'com.ubuntu.update-manager' b'window-width' b'600'
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/update-manager
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with RuntimeError in /usr/lib/python3/dist-packages/gi/overrides/Gtk.py: Gtk couldn't be initialized
UpgradeStatus: Upgraded to quantal on 2012-09-17 (2 days ago)
UserGroups: adm audio cdrom dip fuse libvirtd lpadmin plugdev sambashare sudo www-data

Revision history for this message
Josh Holland (jshholland) wrote :
tags: removed: need-duplicate-check
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Anne (anne-schmidt) wrote :

This bug affects me but I'm having other troubles with the update-manager. Once it has installed updates, it should relaunch itself and check that the system is up-to-date but it doesn't. Most of the time the result is that I can't boot the day after. Today, I had a complete black screen, I could only use the tty. I suspected that the problem came from update manager so I uninstalled it with the option --purge. After that I made an apt-get update, re-installed update-manager and re-run apt-get update. It appeared that some packages, all of them concerning gnome, were not up-to-date. I ran an apt-get upgrade and rebooted. It was the thing to do because it solved the problem.

I'm good! :)

Revision history for this message
jbcolvin (jbcolvin) wrote :

I concur with Anne, or at least with the solution.

I had recently run software-updater under quantal (beta), and foolishly clicked on the partial upgrade option. The system no longer booted properly. tty7 was left with boot messages, but no logon prompt. I logged in under tty1 and ran

> startx&

and this gave me my desktop icons, but no unity plugin stuff (launcher & status bar). I also ran

> unity&

but this complained about no display being set (default = 0 ???), and maybe something about looking for a "core" library.

Anyways, I also had been using apt-get to update upgrade dist-upgrade no no avail. So when I ran...

> sudo apt-get purge update-manager
> sudo apt-get install update-manager

and rebooted, I was pleasantly surprised that everything was working again.

Revision history for this message
Tobiasz Jarczyk (dotnokato-q) wrote :

Hi,
I've crashed update-manager and when trying to report using ubuntu-bug my crash was marked as duplicate of this bug.
And, indeed, traceback is the same.

This is how i got it:
1. Logged to unity as user1.
2. In terminal I relogged to user2 using: su user2
3. As user2 I run update-manager from terminal and got crash:

$ update-manager
No protocol specified

** (update-manager:4253): WARNING **: Could not open X display
No protocol specified,
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 28, in <module>
    from gi.repository import Gtk
  File "/usr/lib/python3/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python3/dist-packages/gi/module.py", line 244, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python3/dist-packages/gi/overrides/Gtk.py", line 1624, in <module>
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized

Now, I understand it is not exactly the same path as people above, but maybe this gives some kind of hint.
Also, maybe some friendlier message for this case?

Revision history for this message
Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug #985969, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers