ERROR:root:getListFromFile: no '/usr/share/update-manager/removal_blacklist.cfg' found: exception during Precise to Quantal upgrade

Bug #1052605 reported by Para Siva on 2012-09-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Desktop ppgrade from Precise to Quantal on mac mini (amd64+mac) crashed with the following stack trace.

ubuntu-1pug@ubuntu1pug-Macmini:/etc/update-manager$ update-manager -c -d
start: Job is already running: apport
ERROR:root:getListFromFile: no '/usr/share/update-manager/removal_blacklist.cfg' found
ERROR:root:not handled expection:
Traceback (most recent call last):

  File "/usr/bin/update-manager", line 113, in <module>

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1748, in doPartialUpgrade

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1145, in doPostUpgrade

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 192, in openCache

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeCache.py", line 114, in __init__

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeConfigParser.py", line 59, in getListFromFile

IOError: [Errno 2] No such file or directory: '/usr/share/update-manager/removal_blacklist.cfg'

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 113, in <module>

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1748, in doPartialUpgrade
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1145, in doPostUpgrade
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 192, in openCache
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeCache.py", line 114, in __init__
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeConfigParser.py", line 59, in getListFromFile
IOError: [Errno 2] No such file or directory: '/usr/share/update-manager/removal_blacklist.cfg'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeViewGtk3.py", line 473, in _handleException
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeApport.py", line 40, in apport_crash
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 95, in apport_excepthook
    if exc_obj.get_dbus_name() == 'org.freedesktop.DBus.Error.ServiceUnknown':
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 501, in add_proc_info
    assert os.path.exists(self['ExecutablePath'])
AssertionError

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 113, in <module>

  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1748, in doPartialUpgrade
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 1145, in doPostUpgrade
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeController.py", line 192, in openCache
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeCache.py", line 114, in __init__
  File "/usr/lib/python2.7/dist-packages/DistUpgrade/DistUpgradeConfigParser.py", line 59, in getListFromFile
IOError: [Errno 2] No such file or directory: '/usr/share/update-manager/removal_blacklist.cfg'

ubuntu-bug update-manager also is also crashing possibly due to the upgrade being unsuccessful. That means no other logs could be attached.

Related branches

Para Siva (psivaa) on 2012-09-19
summary: ERROR:root:getListFromFile: no '/usr/share/update-
- manager/removal_blacklist.cfg' found: exception onPrecise to Quantal
- update crashes on amd64+mac
+ manager/removal_blacklist.cfg' found: exception on Precise to Quantal
+ update on amd64+mac
summary: ERROR:root:getListFromFile: no '/usr/share/update-
- manager/removal_blacklist.cfg' found: exception on Precise to Quantal
- update on amd64+mac
+ manager/removal_blacklist.cfg' found: exception during Precise to
+ Quantal upgrade on amd64+mac
Para Siva (psivaa) on 2012-09-19
tags: added: quantal

precise/Contents-amd64.gz:usr/share/update-manager/removal_blacklist.cfg admin/update-manager-core
quantal/Contents-amd64.gz:usr/share/ubuntu-release-upgrader/removal_blacklist.cfg admin/ubuntu-release-upgrader-core

So if update-manager-core had already been upgraded, then that would sort of explain that, but then why is it still using Python 2? We really need some kind of log files to look into the order of operations here; if you can't use ubuntu-bug, then please just attach a tarball of /var/log/.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Para Siva (psivaa) wrote :

I am able to reproduce this now. All I did was to open and close the software updater before running the upgrade.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

In main.log we see the following:

2012-09-20 15:17:22,048 DEBUG failed to SystemUnLock() (E:Not locked)
2012-09-20 15:17:28,673 ERROR Cache can not be locked (E:Could not get lock //var/lib/dpkg/lock - open (11: Resource temporarily unavailable), E:Unable to lock the administration directory (//var/lib/dpkg/), is another process using it?)

Perhaps the software updater was still doing something?

Brian Murray (brian-murray) wrote :

There is also a strange empty entry in /var/log/apt/history.log

Start-Date: 2012-09-20 15:11:43
End-Date: 2012-09-20 15:11:43

Colin Watson (cjwatson) on 2012-09-20
Changed in update-manager (Ubuntu):
importance: Undecided → High
tags: removed: rls-q-incoming
Michael Vogt (mvo) wrote :

This is really a bit odd, the update-manager "main.log" file stops at 15:17:
2012-09-20 15:17:28,673 ERROR Cache can not be locked (E:Could not get lock //var/lib/dpkg/lock - open (11: Resource temporarily unavailable), E:Unable to lock the administration directory (//var/lib/dpkg/), is another process using it?)

But the apt-term.log contains:
Log started: 2012-09-20 15:31:37
(Reading database ...
..
(Reading database ... 100%
(Reading database ... 140834 files and directories currently installed.)
Removing cmap-adobe-japan2 ...
...
Rebuilding /usr/share/applications/bamf.index...
Log ended: 2012-09-20 16:18:08

Michael Vogt (mvo) wrote :

I suspect what happend is that for some reason the cache was still locked (maybe from PK/aptdaemon) so the release upgrader exited after updateing the sources.list. That then triggered a "partial update" dialog and that the end of the partial upgrade in the cleanup phase it tried to get the remoal blacklist which is no longer on the system.

Michael Vogt (mvo) wrote :

This means:
1. when updating sources.list but not installing any packages it should revert the system state again
2. when the lock is taken it should at either show a message or keep spinning on it for some seconds at least

Michael Vogt (mvo) wrote :

The linked branch addresses point (2).

Michael Vogt (mvo) wrote :

And point (1) is addressed now too

Para Siva (psivaa) on 2012-09-27
summary: ERROR:root:getListFromFile: no '/usr/share/update-
manager/removal_blacklist.cfg' found: exception during Precise to
- Quantal upgrade on amd64+mac
+ Quantal upgrade
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1052605

tags: added: iso-testing
Para Siva (psivaa) wrote :

Once this has happened its almost impossible to recover from this.

running sudo apt-get update && sudo apt-get upgrade does not help ( 266 packages could not be upgraded),

Tried to go in the recovery mode in the grub menu and then select 'dpkg' to Repair broken packages returned with

'E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?'

And rebooting from this state does not let the log-in process succeed, leaving the system unusable

Brian Murray (brian-murray) wrote :

For some reason this wasn't automatically closed.

ubuntu-release-upgrader (1:0.184.1) quantal; urgency=low

  * lp:~mvo/ubuntu-release-upgrader/lp1052605 into lp:ubuntu-release-upgrader:
     - spinning on the dpkg lock for a short while before giving up
     - reverting cleanly if the cache open fails after a sources.list update
       but before anything got installed
     (LP: #1052605)

 -- Michael Vogt <email address hidden> Tue, 02 Oct 2012 18:44:01 +0200

Changed in update-manager (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments