aptdaemon not installed by Depends: update-manager fails

Bug #1046865 reported by Kyle Nitzsche on 2012-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Leadville project
Undecided
Unassigned
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

In systems with install-recommends disabled, aptdaemon is not installed when one installs update-manager. When one runs update-manager, it crashes.

See attached stack trace (also shows apt-cache policy on update-notifier, update-manager and aptdaemon).

The issue is that the Depends path from update-manager includes a Recommends link. See attached aptdaemon-pruned.dot.png. In this, red arrows are Recommends, black arrows are Depends.

A solution may be to add aptdaemon as a direct Depends of update-manager, or perhaps to change python-aptdaemon's Recommend of aptdaemon to a Depend.

Kyle Nitzsche (knitzsche) wrote :
Kyle Nitzsche (knitzsche) wrote :
tags: added: leadville
Brian Murray (brian-murray) wrote :

Discussing this with mvo it seems that making python3-aptdaemon depend on aptdaemon may make the most sense.

Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: xenial
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers