update-manager crashed with SIGSEGV in gtk_tree_view_set_cursor_on_cell()

Bug #1045252 reported by sladner84
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

checked for updates and it crashed.. but before it did I said that I could only do a partial update..

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: update-manager 1:0.168
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu5
Architecture: amd64
CurrentDmesg.txt:
 [ 26.290977] init: plymouth-stop pre-start process (1084) terminated with status 1
 [ 229.886913] show_signal_msg: 30 callbacks suppressed
 [ 229.886921] update-manager[1685]: segfault at 18 ip 00007ffbda2a2555 sp 00007fffd5f3d130 error 4 in libgtk-3.so.0.508.0[7ffbd9ff0000+4d5000]
 [ 335.476976] type=1400 audit(1346666253.033:22): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=478 comm="cupsd" pid=478 comm="cupsd" capability=36 capname="block_suspend"
Date: Mon Sep 3 05:55:47 2012
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1346666205'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'627'
 b'com.ubuntu.update-manager' b'window-width' b'640'
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/update-manager
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7ffbda2a2555: mov 0x18(%rdi),%rbx
 PC (0x7ffbda2a2555) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rbx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: update-manager
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 gtk_tree_view_set_cursor_on_cell () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
Title: update-manager crashed with SIGSEGV in gtk_tree_view_set_cursor_on_cell()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
sladner84 (sladner84) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in update-manager (Ubuntu):
status: New → Invalid
Revision history for this message
Apport retracing service (apport) wrote : Crash report cannot be processed
Download full text (6.1 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.7.1-5ubuntu1 required, but 1:4.7.1-7ubuntu1 is available
update-manager-core version 1:0.168 required, but 1:0.170 is available
python3-minimal version 3.2.3-4 required, but 3.2.3-5 is available
python2.7 version 2.7.3-0ubuntu3 required, but 2.7.3-4 is available
lsb-base version 4.0-0ubuntu22 required, but 4.0-0ubuntu23 is available
libapt-pkg4.12 version 0.9.7.1ubuntu1 required, but 0.9.7.5ubuntu1 is available
python3-dbus version 1.1.0-1ubuntu1 required, but 1.1.1-1 is available
lsb-release version 4.0-0ubuntu22 required, but 4.0-0ubuntu23 is available
libgdk-pixbuf2.0-common version 2.26.1-1ubuntu1 required, but 2.26.3-0ubuntu1 is available
libgtk-3-common version 3.5.8-0ubuntu2 required, but 3.5.12-0ubuntu3 is available
python3.2-minimal version 3.2.3-3 required, but 3.2.3-4 is available
libapt-inst1.5 version 0.9.7.1ubuntu1 required, but 0.9.7.5ubuntu1 is available
dbus version 1.4.18-1ubuntu1 required, but 1.6.4-1ubuntu1 is available
libdconf1 version 0.13.4-0ubuntu1 required, but 0.13.90-0ubuntu1 is available
libatspi2.0-0 version 2.5.4-0ubuntu1 required, but 2.5.5-0ubuntu1 is available
python3-aptdaemon version 0.45+bzr848-0ubuntu1 required, but 0.45+bzr852-0ubuntu2 is available
debconf version 1.5.45ubuntu1 required, but 1.5.46ubuntu1 is available
python3-aptdaemon.gtk3widgets version 0.45+bzr848-0ubuntu1 required, but 0.45+bzr852-0ubuntu2 is available
libk5crypto3 version 1.10.1+dfsg-1 required, but 1.10.1+dfsg-2 is available
python2.7-minimal version 2.7.3-0ubuntu3 required, but 2.7.3-4 is available
libxrandr2 version 2:1.3.2-2 required, but 2:1.4.0-1 is available
libgdk-pixbuf2.0-0 version 2.26.1-1ubuntu1 required, but 2.26.3-0ubuntu1 is available
libkrb5-3 version 1.10.1+dfsg-1 required, but 1.10.1+dfsg-2 is available
libvte-2.90-9 version 1:0.32.2-0ubuntu1 required, but 1:0.33.90-0ubuntu1 is available
libdrm-intel1 version 2.4.37-0ubuntu2 required, but 2.4.38-0ubuntu2 is available
libcomerr2 version 1.42.4-3ubuntu1 required, but 1.42.5-1ubuntu2 is available
python3-gi version 3.3.4-1 required, but 3.3.90-1 is available
gir1.2-vte-2.90 version 1:0.32.2-0ubuntu1 required, but 1:0.33.90-0ubuntu1 is available
python3 version 3.2.3-4 required, but 3.2.3-5 is available
libglib2.0-0 version 2.33.6-1 required, but 2.33.10-0ubuntu3 is available
ubuntu-release-upgrader-gtk version 1:0.173 required, but 1:0.179 is available
libdbus-1-3 version 1.4.18-1ubuntu1 required, but 1.6.4-1ubuntu1 is available
gir1.2-glib-2.0 version 1.33.4-1 required, but 1.33.9-1 is available
libcups2 version 1.5.3-4build1 required, but 1.6.1-0ubuntu5 is available
gir1.2-freedesktop version 1.33.4-1 required, but 1.33.9-1 is available
fontconfig version 2.8.0-3ubuntu9 required, but 2.10.1-0ubuntu3 is available
update-manager version 1:0.168 required, but 1:0.170 is available
libc-bin version 2.15-0ubuntu15 required, but 2.15-0ubuntu17 is available
libbz2-1.0 version 1....

Read more...

tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers