Quantal: Regression: Software-Updater forces user to check for updates

Bug #1024909 reported by MC Return on 2012-07-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Terry

Bug Description

I understand the reason for the new behavior to fix bug 289404 and I've read https://wiki.ubuntu.com/SoftwareUpdates - I can live with the software-updater trying to update before starting, but currently

1. A click on the Cancel button during the software updater's automatic starts check for updates closes the Software Updater completely instead of starting it.
(maybe the user had just run an update or just wants to check something in the software updater, but now he is forced to wait until all updates have finished - that feels like a big regression)

<https://wiki.ubuntu.com/SoftwareUpdates#check-interactive>: "If you stop the check, the progress window should morph into an info alert with the title 'Software Updater' and primary text 'You stopped the check for updates.'..."

2. If any of the repository information fails to download the users only choice is to again close the window (see attached screenshot), which then closes the software-updater instead of opening it and ignoring those failed downloads
(Some index files failed to download. They have been ignored, or old ones used instead.)

This means currently there is no way of opening the software-updater, without finishing a successful update run before.

Related branches

MC Return (mc-return) wrote :

Chromium does not allow me to attach a screenshot here at the moment, so it is missing.
But btw, the "Failed to download repository information" window still says update-manager in its title bar.

Michael Terry (mterry) wrote :

FYI, one workaround is to run it with --no-update:

update-manager --no-update

Michael Terry (mterry) wrote :

Assigning to mpt for an opinion on #1 (i.e. whether that cancel button is for the apt check or the whole update operation).

#2 is likely a bug, unless mpt feels like the sanctity of the upgrades available window can brook no missed indices.

Changed in update-manager (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

Thanks for this report, MC Return. I've updated the specification to cover keeping the UI open if you stop a manual check. This entails changing "Cancel" to "Stop". <https://wiki.ubuntu.com/SoftwareUpdates?action=diff&rev2=80&rev1=78>

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
description: updated
Changed in update-manager (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
Matthew Paul Thomas (mpt) wrote :

As for #2, the updates window absolutely should display despite missed indices, because a PPA long since deleted shouldn't stop one of my colleagues from receiving security updates for several months. Ahem. :-) I guess we should have some kind of persistent warning for that, but just displaying all other updates would be an improvement for now.

Michael Terry (mterry) on 2012-08-20
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: Triaged → In Progress
Michael Terry (mterry) on 2012-08-25
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.170

---------------
update-manager (1:0.170) quantal; urgency=low

  * When user cancels/stops the apt cache update, still let them
    view available updates from a previous cache update. LP: #1024909
 -- Michael Terry <email address hidden> Fri, 24 Aug 2012 19:05:38 -0400

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers