python-minimal dependency blocks LTS upgrade from lucid to precise

Bug #1045926 reported by Bill Hammond
This bug report is a duplicate of:  Bug #990740: upgrading from lucid to precise fails. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager-core (Ubuntu)
New
Undecided
Unassigned

Bug Description

python-minimal is an essential package. In "precise" python-minimal is version 2.7.3, which has dependencies: python2.7-minimal (>= 2.7.3), dpkg (>= 1.13.20). The package python2.7-minimal in "precise" is version 2.7.3 (and it also appears in precise-updates). python2.7-minimal has dependencies: libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libssl1.0.0 (>= 1.0.0), zlib1g (>= 1:1.2.0), python-minimal (>= 2.6.6-3+squeeze1). The python-minimal dependency cannot be met from a fully updated "lucid" where the version of python-minimal is 2.6.5-0ubuntu1.

Furthermore:

1. Ubuntu release: 10.04.4LTS partially upgraded to 12.04, presently stuck in between due to multiple failures in the post first-point-release upgrade action triggered with update manager.

2. Package version: see above. apt-cache policy outputs for 3 packages:
python-minimal:
  Installed: 2.6.5-0ubuntu1
  Candidate: 2.7.3-0ubuntu2
  Version table:
     2.7.3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main Packages
 *** 2.6.5-0ubuntu1 0
        100 /var/lib/dpkg/status
python2.6-minimal:
  Installed: 2.6.5-1ubuntu6
  Candidate: 2.6.5-1ubuntu6
  Version table:
 *** 2.6.5-1ubuntu6 0
        100 /var/lib/dpkg/status
python2.7-minimal:
  Installed: 2.7.3-0ubuntu3.1
  Candidate: 2.7.3-0ubuntu3.1
  Version table:
 *** 2.7.3-0ubuntu3.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main Packages
        100 /var/lib/dpkg/status
     2.7.3-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main Packages

N.B. aptitude reports the state of python2.7-minimal as "unpacked".

3. What expected to happen: N/A

4. What happened: N/A

Revision history for this message
Bill Hammond (gellmu) wrote :

I have no idea why this came up under "util-linux". When it did I tried to change it, but apparently I did not know how to change it.

Revision history for this message
Bill Hammond (gellmu) wrote :

The dependency glitch cited in the description is a problem for the program do-release-upgrade that is part of update-manager-core.

affects: util-linux (Ubuntu) → update-manager-core (Ubuntu)
Revision history for this message
Bill Hammond (gellmu) wrote :

Python is so intertwined with package management that the package management suite should use its own private version of python that is invariant across all releases. (The situation seems to be parallel to that which led sagemath to maintain its own private version of python.)

Revision history for this message
Bill Hammond (gellmu) wrote :

While this is in some unclear way related to bug #990740, it is certainly NOT A DUPLICATE. The incorrect dependency issue for python-minimal is still present (at least on my currently updated version of precise). From "aptitude show python2.7-minimal":

Depends: libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libssl1.0.0 (>= 1.0.0), zlib1g
         (>= 1:1.2.0), python-minimal (>= 2.6.6-3+squeeze1)

In an updated lucid system I'm still running, the version of python-minimal is 2.6.5-0ubuntu1. I believe that with very high
probability an attempt to upgrade it to precise using update-manager will fail unless this dependency issue is addressed.

At the time I reported this bug (2012-09-04) there was no version 2.6.6-3+squeeze1 to be found in ubuntu archives.
In fact, isn't "squeeze" a debian name? How did update-manager manage to import a package with such a dependency?

If there's a reason the dependency in python2.7-minimal must require version >=2.6.6-3, then some such version still needs to be put out for lucid's python-minimal.

ISN'T THIS ALL RATHER OBVIOUS?

Revision history for this message
Bill Hammond (gellmu) wrote :

BTW bug #990740 has been marked invalid. So in saying this bug is a duplicate you are saying this is bug is invalid.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers