[wish] extract multipart files zip archive

Bug #192330 reported by Savvas Radevic on 2008-02-16
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
File Roller
Confirmed
Wishlist
file-roller (Baltix)
Undecided
Unassigned
file-roller (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Hardy by Pedro Villavicencio
unzip (Ubuntu)
Undecided
Unassigned
Declined for Hardy by Pedro Villavicencio

Bug Description

Latest tested release:
Ubuntu Hardy heron 8.04 amd64
Latest tested packages:
file-roller:
  Installed: 2.22.3-0ubuntu1
  Candidate: 2.22.3-0ubuntu1
  Version table:
 *** 2.22.3-0ubuntu1 0
        500 http://nl.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.2-0ubuntu1 0
        500 http://nl.archive.ubuntu.com hardy/main Packages
unzip:
  Installed: 5.52-10ubuntu2
  Candidate: 5.52-10ubuntu2
  Version table:
 *** 5.52-10ubuntu2 0
        500 http://nl.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Original description:
Ubuntu Gutsy gibbon 7.10 amd64
(I have installed p7zip p7zip-full rar unrar)
I tried to unzip multipart file archive (Fink.zip Fink.z01 Fink.z02 Fink.z03).

Right click -> extract here and it outputs this error:

warning [/home/username/Desktop/Fink.zip]: zipfile claims to be last disk of a multi-part archive;
  attempting to process anyway, assuming all parts have been concatenated
  together in order. Expect "errors" and warnings...true multi-part support
  doesn't exist yet (coming soon).
file #1: bad zipfile offset (local header sig): 4
file #2: bad zipfile offset (local header sig): 27969969
file #3: bad zipfile offset (lseek): 49012736

Then tried the command: 7za x Fink.zip
with this error:

7-Zip (A) 4.51 beta Copyright (c) 1999-2007 Igor Pavlov 2007-07-25
p7zip Version 4.51 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,2 CPUs)
Processing archive: Fink.zip
Error: Can not open file as archive

I even tried unrar / rar and they don't support the file. It looks like they can't handle multipart zip files.
The multipart files were extracted successfully in a Windows environment, using Winrar 3.71
Could this be fixed in Ubuntu Hardy Heron 7.04 ?

description: updated
description: updated
Michael Nagel (nailor) wrote :

thanks for reporting this bug. i fear you'll have to file it against one specific application and request support for it. right now it wont get noticed by the developers. feel free to reopen this bug and assign it to some package.

Savvas Radevic (medigeek) wrote :

switching to new again, assigned to file-roller package

Changed in file-roller:
status: Invalid → New
Savvas Radevic (medigeek) wrote :

As explained in "man unzip":
"Multi-part archives are not yet supported, except in conjunction with zip. (All parts must be concatenated together in order, and then "zip -F" must be performed on the concatenated archive in order to "fix" it.) This will definitely be corrected in the next major release."

This should be fixed however, until the 'real' multi-part support arrives with the 6.0 release

Note: Ubuntu could use the betas for 6.0 in the devel releases, providing extra bug triaging.

description: updated
Pedro Villavicencio (pedro) wrote :

I'm declining the stable release nominations on this bug, since it doesn't meet the requirements for stable updates (https://wiki.ubuntu.com/StableReleaseUpdates).

Also it should send upstream to bugzilla.gnome.org to see what the file-roller developers think about it, leaving as incomplete until that, thanks.

Changed in file-roller:
status: New → Incomplete
Savvas Radevic (medigeek) wrote :

I can't remember if the nomination was set before hardy or any of its alpha versions were released. Anyway, I'll report the bug at gnome :)

Pedro Villavicencio (pedro) wrote :

great, thanks for sent it upstream.

Changed in file-roller:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Incomplete → Triaged
Changed in fileroller:
status: Unknown → New
Jason Ribeiro (jrib) on 2008-10-11
Changed in fileroller:
status: New → Unknown
Changed in fileroller:
status: Unknown → Confirmed
Changed in file-roller:
importance: Unknown → Wishlist
Gvozdik Artem (gvozdik) on 2010-11-23
Changed in unzip (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.