[SRU] unzip list utf-8 (non-ascii) filenames as ??

Bug #1199239 reported by Ma Hsiao-chun on 2013-07-09
118
This bug affects 57 people
Affects Status Importance Assigned to Milestone
unzip (Debian)
Fix Released
Unknown
unzip (Ubuntu)
Undecided
Unassigned
Precise
High
Brian Murray
Quantal
High
Brian Murray
Raring
High
Brian Murray

Bug Description

[Impact]
Despite notorious LP #580961 , the biggest issue of current unzip is that it always list non-ASCII file name character as question mark (?) .

Even though handling Zip archives with non-standard encoding (neither CP437 nor UTF-8) can be tricky, we should support UTF-8 Zip archives out of the box as it's the standard and it become more and more popular now.

Newer version of unzip in Debian and Ubuntu (13.10+) fixed the issue by changing build configuration already. The fix is visible to File Roller and Ark also.

The issue remains in 12.04 - 13.04 currently. We need to apply the same fix for them.

[Test Case]
touch naïve.txt
touch 天真.txt
zip test.zip naïve.txt 天真.txt
unzip -l test.zip

With unzip -l you should not see question marks in the filenames.

ark test.zip
file-roller test.zip # the result may be different see notes below

[Regression Potential]
Little, if any, as the proposed fix is used by Debian, Ubuntu 13.10+ and openSUSE (using a different approach to archive exactly same effect) already.

[Other Info]
The fix for this bug also fixes bug 580961, however that bug had so much history I (bdmurray) decided not to make one the duplicate of the other and just also include that bug number in the changelog.

Note that Ark is the better frontend software for testing, as it seems to use unzip backend exclusively. File roller, on the other hand, will use 7z backend when 7z exists, so the issue can magically disappear some time (7z support utf8 filenames correctly). 7z isn't included on the ISO, though.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unzip (Ubuntu):
status: New → Confirmed
Ma Hsiao-chun (mahsiaochun) wrote :

As I checked Debian Changlog: http://ftp-master.metadata.debian.org/changelogs//main/u/unzip/unzip_6.0-9_changelog

The problem is resolved by a similar way in unzip_6.0-9 The change has been synced to Ubuntu saucy already. The remaining affected series are precise, quantal and raring.

tags: added: precise quantal raring
removed: saucy

The attachment "unzip-dont_call_isprint.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

description: updated
summary: - Do not call isprint when listing
+ unzip list utf-8 (non-ascii) filenames as ??, also affects file roller
+ and ark
summary: - unzip list utf-8 (non-ascii) filenames as ??, also affects file roller
- and ark
+ unzip list utf-8 (non-ascii) filenames as ??
description: updated
description: updated
summary: - unzip list utf-8 (non-ascii) filenames as ??
+ [SRU] unzip list utf-8 (non-ascii) filenames as ??
description: updated
description: updated
tags: removed: patch
description: updated
description: updated
description: updated
Brian Murray (brian-murray) wrote :

This is fixed in Saucy and Trusty so I'm setting that task to Fix Released.

Changed in unzip (Ubuntu):
status: Confirmed → Fix Released
Changed in unzip (Ubuntu Precise):
status: New → In Progress
Changed in unzip (Ubuntu Quantal):
status: New → In Progress
Changed in unzip (Ubuntu Raring):
status: New → In Progress
Changed in unzip (Ubuntu Precise):
assignee: nobody → Brian Murray (brian-murray)
Changed in unzip (Ubuntu Quantal):
assignee: nobody → Brian Murray (brian-murray)
Changed in unzip (Ubuntu Raring):
assignee: nobody → Brian Murray (brian-murray)
Changed in unzip (Ubuntu Precise):
importance: Undecided → High
Changed in unzip (Ubuntu Quantal):
importance: Undecided → High
Changed in unzip (Ubuntu Raring):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I've upload this to P, Q, and R. Thanks for identifying the fix and bringing this to our attention.

description: updated
Changed in unzip (Debian):
status: Unknown → Fix Released

Hello Ma, or anyone else affected,

Accepted unzip into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unzip/6.0-8ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unzip (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in unzip (Ubuntu Quantal):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Ma, or anyone else affected,

Accepted unzip into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unzip/6.0-7ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Ma, or anyone else affected,

Accepted unzip into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unzip/6.0-4ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unzip (Ubuntu Precise):
status: In Progress → Fix Committed
Ma Hsiao-chun (mahsiaochun) wrote :

Thank you very much Brian.

Works for me on precise.

glitsj16 (glitsj16) wrote :

Thanks Brian.

Confirming fix works on raring.

tags: added: verification-done-precise verification-done-raring
Ma Hsiao-chun (mahsiaochun) wrote :

Verified on quantal.

Aron Xu (happyaron) on 2013-11-10
tags: added: verification-done
removed: verification-done-precise verification-done-raring verification-needed
tags: added: verification-done-precise verification-done-quantal verification-done-raring
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unzip - 6.0-4ubuntu2

---------------
unzip (6.0-4ubuntu2) precise-proposed; urgency=low

  * Fix incorrectly displayed file names with UTF-8 characters.
    Add -DNO_WORKING_ISPRINT to build flags. (LP: #1199239, LP: #580961)
 -- Brian Murray <email address hidden> Wed, 06 Nov 2013 10:21:26 -0800

Changed in unzip (Ubuntu Precise):
status: Fix Committed → Fix Released
Ma Hsiao-chun (mahsiaochun) wrote :

Fix not released for Quantal and Raring?

On Fri, Nov 15, 2013 at 03:11:06AM -0000, Ma Xiaojun wrote:
> Fix not released for Quantal and Raring?

Nobody, has verified the test case in bug 580961 for quantal and raring.

--
Brian Murray
Ubuntu Bug Master

Ma Hsiao-chun (mahsiaochun) wrote :

Comment 11 and comment 12 are verifications for quantal and raring.

Ma Hsiao-chun (mahsiaochun) wrote :

Ping?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unzip - 6.0-8ubuntu2

---------------
unzip (6.0-8ubuntu2) raring-proposed; urgency=low

  * Fix incorrectly displayed file names with UTF-8 characters.
    Add -DNO_WORKING_ISPRINT to build flags. (LP: #1199239, LP: #580961)
 -- Brian Murray <email address hidden> Wed, 06 Nov 2013 09:40:08 -0800

Changed in unzip (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unzip has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unzip - 6.0-7ubuntu1.1

---------------
unzip (6.0-7ubuntu1.1) quantal-proposed; urgency=low

  * Fix incorrectly displayed file names with UTF-8 characters.
    Add -DNO_WORKING_ISPRINT to build flags. (LP: #1199239, LP: #580961)
 -- Brian Murray <email address hidden> Wed, 06 Nov 2013 10:31:34 -0800

Changed in unzip (Ubuntu Quantal):
status: Fix Committed → Fix Released
Bib (bybeu) wrote :

Thank you very much. Now no more this issue in raring :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.