unrar-nonfree does not recognise windows cp1250 encoding

Bug #379119 reported by VladimirCZ on 2009-05-21
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
unrar-nonfree (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: file-roller

Recognition of windows cp1250 encoding fails at archives compressed under MS Windows into .zip or .rar format of compressed container, but works well with .7z archives.

Examples attached:
1) Latina.7z ... compressed with the latest 7-zip software under MS Windows XP SP3
2) Latina.zip ... compressed with the latest 7-zip software under MS Windows XP SP3
3) Latina.rar ... compressed with WinRar 2.5 (no unicode support) software under MS Windows XP SP3
The file-roller for
1) 7z: works well
2) zip: extraction done properly, but accented characters are replaced with "?"
2) rar: extraction produces unusable files, when there is an accented character in the path or in the filename of such files.

Detected under:
Ubuntu 9.04 64-bit with non-free unrar installed.

VladimirCZ (vlabla) wrote :
VladimirCZ (vlabla) wrote :
VladimirCZ (vlabla) wrote :
Chris Coulson (chrisccoulson) wrote :

That isn't a file-roller bug. For me, the zip file works perfectly ok in file-roller. The rar file fails in the way that you describe, but also fails when running unrar-nonfree from the command line too.

affects: file-roller (Ubuntu) → unrar-nonfree (Ubuntu)
Changed in unrar-nonfree (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - file-roller does not recognise windows cp1250 encoding
+ unrar-nonfree does not recognise windows cp1250 encoding
VladimirCZ (vlabla) wrote :

Hello Chris,
Thank you for sorting out this problem.
Let me ask you about the performance with the ".zip " file:
Have you made some special settings that could effect recognition of encoding of ".zip" files?
Because what I see and get after extraction is on the attached screen-shot.

Vinagre (vinagr3) wrote :

This is a problem only because the package installs the unrar 32 bit in ubuntu 64bit.

I tested the unrar 64bit downloaded from the official site and I had no problem.

My script to install rar and unrar 64bit in attachment

VladimirCZ (vlabla) wrote :

I have tried the script, installed the 64bit version, tried to uncompress the Latina.rar file and still the same problem with unrecognised characters. So I returned to my previous install.

Ma Hsiao-chun (mahsiaochun) wrote :

How can you expect magic happens when the archive itself doesn't support Unicode?

You can run 7-zip or WinRAR with wine, though.
Given proper locale environmental variables passed to wine, archivers on behaves exactly same as that of Windows.

Ma Hsiao-chun (mahsiaochun) wrote :

For the zip issue, check bug 1199239

Ma Hsiao-chun (mahsiaochun) wrote :

For the rar issue, non-Unicode rar archives are very rare now.
If you encounter, you may use unar [1] to decompress them.
http://packages.ubuntu.com/search?keywords=unar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers