xcwcp doesn't use pulseaudio

Bug #1854630 reported by Koos van den Hout on 2019-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unixcw (Ubuntu)
Undecided
Unassigned

Bug Description

I tried xcwcp on a system with a fresh ubuntu 18.04 LTS install with ubuntu-hams-updates ppa installed. It gave an error on the commandline:

xcwcp: PulseAudio output not available (device: ( default ))

with pulseaudio being available fine, so I expected it to use pulseaudio.

With strace I found it tries to use libpulse-simple.so which is not available. I fixed it by making a softlink

/usr/lib/x86_64-linux-gnu$ sudo ln -sf libpulse-simple.so.0 libpulse-simple.so

So this is an incompatibility between a freshly installed libpulse0 and xcwcp.

xcwcp:
  Installed: 3.5.1-2
  Candidate: 3.5.1-2
  Version table:
 *** 3.5.1-2 500
        500 http://nl.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libpulse0:
  Installed: 1:11.1-1ubuntu7.2
  Candidate: 1:11.1-1ubuntu7.2
  Version table:
 *** 1:11.1-1ubuntu7.2 500
        500 http://nl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:11.1-1ubuntu7 500
        500 http://nl.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xcwcp 3.5.1-2
ProcVersionSignature: Ubuntu 4.15.0-70.79-generic 4.15.18
Uname: Linux 4.15.0-70-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.9
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Dec 1 15:19:37 2019
InstallationDate: Installed on 2018-12-22 (343 days ago)
InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: unixcw
UpgradeStatus: No upgrade log present (probably fresh install)

Koos van den Hout (koos-kzdoos) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers