Menus that fill themselves on QMenu::aboutToShow don't work

Bug #1664578 reported by Albert Astals Cid
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qtubuntu (Ubuntu)
Fix Released
Undecided
Albert Astals Cid
unity8 (Ubuntu)
Fix Released
Undecided
Albert Astals Cid

Bug Description

Our menu implementation doesn't trigger QMenu::aboutToShow so some menus in konsole and kate show up empty.

Related branches

Revision history for this message
Albert Astals Cid (aacid) wrote :

Example application

Changed in qtubuntu (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
assignee: Nick Dedekind (nick-dedekind) → Albert Astals Cid (aacid)
Changed in qtubuntu (Ubuntu):
assignee: Nick Dedekind (nick-dedekind) → Albert Astals Cid (aacid)
description: updated
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Changed in qtubuntu (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.15+17.04.20170321-0ubuntu1

---------------
unity8 (8.15+17.04.20170321-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Signal aboutToShow (LP: #1664578)
  * Support Panel top level items to be disabled (LP: #1670694)
  * Improve Launcher ←→ touch menu interaction (LP: #1667620, #1671069)
  * Fix real world submenus (e.g. kate) not getting their first item
    selected on open (LP: #1666859)

  [ Daniel d'Andrada ]
  * Really disable the window decoration when in staged mode (LP:
    #1670361)
  * Don't let clients resize their surfaces while in staged
    (phone/tablet) mode (LP: #1670390)
  * TopLevelWindowModel: don't put hidden windows in the model (LP:
    #1665286)

  [ Lukáš Tinkl ]
  * Reset always-show-osk gsetting on startup to default value (false
    atm)
  * Fix the restored-to position with Miral due to the state changes
    being async (LP: #1669819)
  * Add a cursor name fallback mapping "grabbing" -> "closedhand" for
    Breeze
  * Fix unsnapping a maximized window from the panel (LP: #1671721)
  * Disable altDrag feature outside windowed mode

  [ Michael Terry ]
  * Don't lock the screen for guest users or users in the nopasswdlogin
    group. (LP: #1644237)
  * Support GNOME-style logout DBus API (making the Logout, Reboot, and
    Shutdown launcher commands work) (LP: #1673229)

  [ Michael Zanetti ]
  * Add support for closing apps from the spread with "Q" (LP: #1670327)
  * hide "private" launcher quicklist entries when the greeter is locked
    (LP: #1667649)
  * add surface titles to launcher's quicklist (LP: #1661668)
  * properly reset the drawer state when cancelling a horizontal drag
    (LP: #1669536)
  * fix the focus moving correctly between launcher and drawer (LP:
    #1669880)
  * unfocus the drawer's textfield when it is moved (LP: #1669839)

  [ Pete Woods ]
  * Fix up indicators-client after refactoring (LP: #1672797)

 -- Michał Sawicz <email address hidden> Tue, 21 Mar 2017 10:58:13 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.64+17.04.20170320-0ubuntu1

---------------
qtubuntu (0.64+17.04.20170320-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Set qtubuntu-tag and handle aboutToShow calls (LP: #1664578)
  * Set enabled state for menus in the submenu-enabled property since
    GMenuModel doesn't support that concept (LP: #1670694)
  * fix image conversion to Format_ARGB32
  * Build with clang

  [ Gerry Boland ]
  * Use correct parented/parentless dialog and utility window types from
    Mir

 -- Lukáš Tinkl <email address hidden> Mon, 20 Mar 2017 17:31:42 +0000

Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments