Searching with the app drawer causes Unity 8 to crash in some circumstances

Bug #1658190 reported by Larry Price on 2017-01-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
High
Michael Zanetti

Bug Description

Latest zesty
unity8 8.15+17.04.20170110.4-0ubuntu1

Searching rapidly for apps in the app drawer is causing a crash for me. I have quite a few applications (including libertine apps) available. To reproduce:

1. Open app drawer
2. Enter a few characters to match an app
3. Clear searchbar with backspaces
4. Goto step 2 (switching characters from time to time)

This crashes Unity 8 for me sometimes as quickly as 20 searches, but other times it takes up to 50 searches.

Related branches

Michał Sawicz (saviq) on 2017-01-23
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Zanetti (mzanetti)
Michael Zanetti (mzanetti) wrote :

I've tried this for a while now but couldn't see it happen. Would it be possible for you to attach a stack trace?

Larry Price (larryprice) wrote :

running "bt full" in gdb: https://paste.ubuntu.com/23852354/

and all the threads: https://paste.ubuntu.com/23852359/

Larry Price (larryprice) wrote :

Testing out the new branch, I seem to run into the same issue: https://paste.ubuntu.com/23853150/

Michael Zanetti (mzanetti) wrote :

Are you really sure you used the new packages? The lines in the stack trace indicate you'd still be running the original packages.

Larry Price (larryprice) wrote :

Hmm `apt-cache policy unity8` returned:

    8.15+17.04.20170110.4+fetch3933bzr2740-0ubuntu1

I can try to download/install the packages again.

Larry Price (larryprice) wrote :

Here's the new backtrace: https://paste.ubuntu.com/23858569/

Larry Price (larryprice) wrote :

I'm also able to reproduce this consistently in a kvm running xenial+overlay. Perhaps this has something to do with calling into libubuntu-app-launch to get libertine apps? I've got plenty of libertine apps in both of these environments that I search for.

Larry Price (larryprice) wrote :

I did an experiment where I removed any libertine apps from my system. At that point, I was unable to reproduce this defect. Then I installed "sakura" and "xterm" directly on my system and tried again. When alternating between searching for sakura and xterm in the search bar, I consistently see this crash. The crash *always* happens after I type "sa" but before the "a" appears in the search bar. "sakura" shows up in the app drawer, but the system then hangs briefly and crashes.

Michael Zanetti (mzanetti) wrote :

Ok, I can reproduce this now. Some findings:

I seems to only happen when searching for "xt" (xterm), then searching something in the "S" section and when the search result gives only one result within that section after the second letter. E.g. for me it crashes when searching for "sa" (sakura), "su" (sudoku) and "sn" (screenshot) but not with anything else in the "S" section.

Also, the "S" section is the largest one for me. I could not find any other section where it happens.

Michael Zanetti (mzanetti) wrote :

The speed at which the search is done doesn't matter... It is even possible to

search "xterm", delete that, type "s", switch to another vt, attach gdb to unity8, switch back and then type "a" to make it happen.

Sadly, the stack traces always seem to end up in some Qt metacall magic for invalidating the filters.

summary: - Searching rapidly with the app drawer causes Unity 8 to crash
+ Searching with the app drawer causes Unity 8 to crash in some
+ circumstances
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.15+17.04.20170216.1-0ubuntu1

---------------
unity8 (8.15+17.04.20170216.1-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Make menus items close the menu when clicking on them (LP: #1657082,
    #1657399)
  * Clicking on an open menu closes it + test
  * Make the menus and submenus do not go outside the screen when
    popping out
  * Auto open submenus on hover (LP: #1657085)
  * Make the double click on a menu not be maximize the window below
    (LP: #1657079)
  * Make the MenuBar InverseMouseArea eat hover events when there's a
    popup open (LP: #1657763)
  * Make double click on the window decoration maximize (LP: #1657758)
  * Eat hover events when the launcher quicklist is open (LP: #1640776)
  * Remove TODO now that we require Qt > 5.5
  * Serialize two make targets that want to cp to the same target file
    (LP: #1660576)
  * Remove variable that is always false (LP: #1585910)

  [ Daniel d'Andrada ]
  * Consolidate launcher API checks

  [ Lukáš Tinkl ]
  * Fixes for activating minimized windows and restoring fullscreen ones
    (LP: #1656808, #1658937, #1658938)

  [ Michael Zanetti ]
  * move right edge push area up some levels so it can be used on top of
    the indicators
  * fix minimizing/restoring transitions (LP: #1658936)
  * fix some glitches with spread positioning
  * fix jumpy animation when closing an item from the spread
  * Show the wallpaper while the focused app is moving in staged mode
    (LP: #1648251)
  * Update the tutorial to mention the app drawer instead of the dash on
    long left edge swipe (LP: #1658932)
  * prevent hiding the launcher when the mouse hover event is eaten by
    the EdgePushArea (LP: #1657045)
  * properly invalidate the whole model (LP: #1658190)
  * stabilize OrientedShell test (LP: #1658994)

  [ Nick Dedekind ]
  * Added overflow support to application menus.
  * Updated menu colors

 -- Michał Sawicz <email address hidden> Thu, 16 Feb 2017 13:49:18 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers