unity8 crash after create a new online account

Bug #1655644 reported by Renato Araujo Oliveira Filho
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtmir (Ubuntu)
Fix Released
High
Gerry Boland
unity8 (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Ubuntu xenial with overlay ppa.
Unity8 installed from ppa (debian).
arch: amd64

Unity8 crashes after create a new account

How to reproduce:

1- start system settings
2- Go to online accounts
3- Click to create a new account
4- Choose any account on the list (Eg. google)
5- Follow the steps to create the new account
6- After create the account click on it

Expected

Show Account information

Current

Unity8 crash.

Related branches

Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

Back trace:

#0 0x00007f2373dca4d0 in Protocol::features() const () from /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Telephony/libtelephonyservice-qml.so
#1 0x00007f2373db3410 in AccountList::filterAccounts() () from /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Telephony/libtelephonyservice-qml.so
#2 0x00007f23b1c51c34 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3 0x00007f2373da2d0a in TelepathyHelper::onNewAccount(Tp::SharedPtr<Tp::Account> const&) () from /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Telephony/libtelephonyservice-qml.so
#4 0x00007f2373dacbc1 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Telephony/libtelephonyservice-qml.so
#5 0x00007f23b1c51b81 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6 0x00007f23737517d2 in Tp::AccountManager::newAccount(Tp::SharedPtr<Tp::Account> const&) () from /usr/lib/x86_64-linux-gnu/libtelepathy-qt5.so.0
#7 0x00007f2373754bb7 in ?? () from /usr/lib/x86_64-linux-gnu/libtelepathy-qt5.so.0
#8 0x00007f23b1c51b81 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9 0x00007f237393ea6f in Tp::PendingOperation::finished(Tp::PendingOperation*) () from /usr/lib/x86_64-linux-gnu/libtelepathy-qt5.so.0
#10 0x00007f237393fed0 in ?? () from /usr/lib/x86_64-linux-gnu/libtelepathy-qt5.so.0
#11 0x00007f23b1c52729 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f23b1c2515a in QCoreApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f23b1c252b8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f23b1c2717a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f23b1c79f63 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f23ae8351a7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f23ae835400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f23ae8354ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f23b1c7a36f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f23b1c2300a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f23b1c2b6cc in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00000000004079fa in ?? ()
#23 0x00007f23b1062830 in __libc_start_main (main=0x4077e0, argc=2, argv=0x7fff0b10e9a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0b10e998)
    at ../csu/libc-start.c:291
#24 0x0000000000407bd9 in _start ()

Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

this was caused by a developer branch. And was fixed before the release.

Changed in unity8 (Ubuntu):
status: New → Invalid
Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

Reopening the bug since this still causing unity8 crash even using only packages from overlay.

description: updated
Changed in unity8 (Ubuntu):
status: Invalid → New
Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

New backtrace:

Thread 1 "unity8" received signal SIGSEGV, Segmentation fault.
0x00007f31108325a5 in qtmir::SurfaceManager::onWindowRemoved(miral::WindowInfo const&) () from /usr/lib/x86_64-linux-gnu/qt5/qml/Unity/Application/libunityapplicationplugin.so
(gdb) bt
#0 0x00007f31108325a5 in qtmir::SurfaceManager::onWindowRemoved(miral::WindowInfo const&) () from /usr/lib/x86_64-linux-gnu/qt5/qml/Unity/Application/libunityapplicationplugin.so
#1 0x00007f3146399729 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2 0x00007f314636c15a in QCoreApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3 0x00007f314636c2b8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4 0x00007f314636e17a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5 0x00007f31463c0f63 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6 0x00007f3142f7c1a7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007f3142f7c400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8 0x00007f3142f7c4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9 0x00007f31463c136f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f314636a00a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f31463726cc in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00000000004079fa in ?? ()
#13 0x00007f31457a9830 in __libc_start_main (main=0x4077e0, argc=2, argv=0x7fff1c7fca88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff1c7fca78)
    at ../csu/libc-start.c:291
#14 0x0000000000407bd9 in _start ()

description: updated
Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

this only happen on unity8 does not happen on unity7 (launching unity8 ubuntu-system-settings)

Michał Sawicz (saviq)
Changed in qtmir (Ubuntu):
status: New → Invalid
Michał Sawicz (saviq)
Changed in qtmir (Ubuntu):
status: Invalid → New
Changed in unity8 (Ubuntu):
status: New → Invalid
Bill Filler (bfiller)
Changed in qtmir (Ubuntu):
importance: Undecided → High
assignee: nobody → kevin gunn (kgunn72)
kevin gunn (kgunn72)
Changed in qtmir (Ubuntu):
assignee: kevin gunn (kgunn72) → Gerry Boland (gerboland)
Bill Filler (bfiller)
summary: - unity8 crash after create a new account
+ unity8 crash after create a new online account
Revision history for this message
Gerry Boland (gerboland) wrote :

Relevant unity8.log output before crash:

http://pastebin.ubuntu.com/23874565/

Revision history for this message
Gerry Boland (gerboland) wrote :

One backtrace, slightly confusing: http://pastebin.ubuntu.com/23874652/

Gerry Boland (gerboland)
Changed in qtmir (Ubuntu):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.5.1+17.04.20170320.1-0ubuntu1

---------------
qtmir (0.5.1+17.04.20170320.1-0ubuntu1) zesty; urgency=medium

  [ Alan Griffiths ]
  * Reduce dependencies on mirserver by reworking
    ../Application/mirbuffersgtexture.cpp and
    ../Application/surfacemanager.cpp

  [ Andreas Pokorny ]
  * Attach MirInputDeviceId and the MirCookie to input events (LP:
    #1536279, #1668692)

  [ Daniel d'Andrada ]
  * Implement MirSurface::allowClientResize (LP: #1670390)

  [ Gerry Boland ]
  * Stop MirSurface deleting itself, ensure SurfaceManager alone manages
    MirSurface lifetimes. Add SurfaceManager test suite. (LP: #1655644)
  * Extend timeouts when running under valgrind

  [ Albert Astals Cid, Gerry Boland ]
  * Check for find() result not being null before using it

 -- Michał Sawicz <email address hidden> Mon, 20 Mar 2017 21:16:34 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers