unity8 fails to build in arm64 because of tests segfault

Bug #1641175 reported by Marco Trevisan (Treviño) on 2016-11-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Critical
Unassigned
unity8 (Ubuntu)
Critical
Unassigned

Bug Description

Recent builds of unity8 fails in arm64 because of this error

See for example: https://launchpadlibrarian.net/293000651/buildlog_ubuntu-zesty-arm64.unity8_8.15+17.04.20161111.1-0ubuntu1_BUILDING.txt.gz

21/23 Test #18: testUtilsStyle ...................***Exception: SegFault 0.43 sec

https://launchpadlibrarian.net/292999853/buildlog_ubuntu-xenial-arm64.ubuntu-system-settings_0.4+16.04.20161111-0ubuntu1_BUILDING.txt.gz

29/29 Test #29: tst_notifications ...................***Failed 0.62 sec
Segmentation fault (core dumped)

(gdb) ========= End of stack trace ==============
QFATAL : TrustStoreModelTest::testEmpty() Received signal 11
         Function time: 6ms Total time: 7ms
FAIL! : TrustStoreModelTest::testEmpty() Received a fatal error.
   Loc: [Unknown file(0)]
Totals: 1 passed, 1 failed, 0 skipped, 0 blacklisted
********* Finished testing of TrustStoreModelTest *********
Aborted (core dumped)

summary: - unity8 fails to build in arm64 because of pragma Singleton
+ unity8 fails to build in arm64 because of tests segfault
description: updated
Changed in ubuntu-system-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
description: updated

It was probably something temporary... It works now.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Fix Released
Changed in unity8 (Ubuntu):
status: Triaged → Fix Released
Michał Sawicz (saviq) wrote :

Well, we still need to look at it and at least try and reproduce ;)

Changed in unity8 (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Jonas G. Drange (jonas-drange) wrote :
Changed in ubuntu-system-settings (Ubuntu):
status: Fix Released → Confirmed
Albert Astals Cid (aacid) wrote :

Isn't this the "Qt doesn't like the new arm64 kernel" bug we already had that made us revert the kernel?

Timo Jyrinki (timo-jyrinki) wrote :

The general problem is that the new kernel comes back at each upgrade of the ubuntu kernel, and a custom one needs installation for each. But yes bug #1630906 is still open.

Qt 5.7.1 and 5.6.3 (in March or so) will eventually have upstream fixes that hopefully work fully unlike the cherry-picks that had their own issues in my testing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers